diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Solid State (http://www.diyaudio.com/forums/solid-state/)
-   -   Cyrus Two not working (http://www.diyaudio.com/forums/solid-state/227694-cyrus-two-not-working.html)

Mikechaj 13th January 2013 02:02 PM

Cyrus Two not working
 
Hi all
A few years ago I bought a second hand Cyrus 2 and PSX for my neighbour - all has been fine including reconnecting the set up at his new house...since last week there is no sound on any input.. He is using an iPod on a dock and a cd player...no sound on any input. There is a click in the speakers when disconnecting inputs on low volume but no sound when touching any of the phono plugs.

Both lights are on on the amp and PSX. I haven't tried opening up the amp and cleaning the volume and input switches.

Any advice?

Many thanks
Mike

TANDBERGEREN 13th January 2013 02:59 PM

Click in the speakers when switching off tells us the powerAmp is OK.
I am not sure, but i believe the two fuses inside both are for the power amp, 1,5A or so, aren't they?
But You might try to check them anyway.

Else there isn't much to check if You aren't trained in electronics to fix.

Mikechaj 13th January 2013 03:24 PM

No click when switching off ...I will check the inner fuses althoughbibbelievevthe Cyrus 2 won't have them installed as its being used with the PSX? Mike

Ian Finch 13th January 2013 04:52 PM

Quote:

Originally Posted by Mikechaj (Post 3323938)
No click when switching off ...I will check the inner fuses althoughbibbelievevthe Cyrus 2 won't have them installed as its being used with the PSX? Mike

Before guessing and pulling things apart without knowing what to search for, remove all input and output leads and measure the voltage between the output terminals to get an indication whether either amplifier is damaged or not. Get a DMM and set it to volts DC, using autorange or starting at 200V and working down until you get a stable reading which should be no more than 40mV.

You may only have a problem with the preamp and that will be less of a difficulty. Also, check out the many Cyrus 2 problem threads already here, with the search button, top of page.

ftpols 13th January 2013 10:20 PM

Cyrus Two not working
 
The Cyrus isn't set up correctly ("Both lights are on on the amp and PSX."). You need to open the Cyrus II and remove the two on board fuses if you you are going to power it from the PSX. Connect the power cable to the PSX and the umbilical from the PSX to the Cyrus II. Then when you power on the PSX only the PSX power lamp will light.

But first of all, try connecting the power cord to the Cyrus II with the fuses installed in the Cyrus II. Then remove the power cord and onboard fuses and hook up the PSX as explained above. That might give you a clue as to which unit is faulty. The next step is to troubleshoot the defect as suggested by Ian Finch.

PS. Before I start testing or replacing parts, I always disconnect the power supply and press the power switch for about 20 seconds to discharge the capacitors.

Best of luck. It's a great amp and worth repairing.

Ian Finch 15th January 2013 03:19 AM

Since the amplifier was working (presumably with the PSX fitted) for your neighbour, I guessed the fuse issue was eliminated. So, any news Mikechaj? Problem solved?


All times are GMT. The time now is 11:06 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2