cambridge audio c500 and p500 help - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th January 2013, 05:18 PM   #1
diyAudio Member
 
Join Date: Jan 2013
Default cambridge audio c500 and p500 help

Hi friends
I got a cambridge audio c500 pre amplifier and two cambridge p500 power amplifier from a garage sale. I dont know how how to connect this amps and also i am afraid to connect by my own with out any idea . I will be happy if anybody can provide me the user manual or diagram or photo to interface the system. I could able to find the user manual of this classic audio system thank you.

I have attached the front and back photos of the amplifiers. Thank you

Wondipuli
Attached Images
File Type: jpg IMG_0002.jpg (517.1 KB, 266 views)
File Type: jpg IMG_0001.jpg (672.2 KB, 241 views)
  Reply With Quote
Old 10th January 2013, 05:46 PM   #2
diyAudio Member
 
Join Date: Jan 2013
If possible please you can mail me at wondipuli@gmail.com.
  Reply With Quote
Old 10th January 2013, 06:08 PM   #3
Puffin is offline Puffin  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: U.K
I have these amplifiers. The C500 pre-amp has two sets of pre-outs. Use one of these pairs to connect to the input 1 (in) L&R of one P500 and the other pre-out to the input (in) L&R of the second P500.
  Reply With Quote
Old 10th January 2013, 06:21 PM   #4
diyAudio Member
 
Join Date: Jan 2013
Default Hi Puffin

Hi Puffin
I did the same but there is no sound in speakers. Is it possible to hear the click sound of relay switch inside when switching on? i can see the green LED glowing
i followed the procedure from the image attached.
Attached Images
File Type: jpg amp.jpg (164.6 KB, 223 views)
  Reply With Quote
Old 11th January 2013, 05:34 PM   #5
diyAudio Member
 
Join Date: Jan 2013
Default User manual of Cambridge audio C500 and P500

Today i got reply from the cambridge audio with its user manual. I have attached the user manual in PDF format. Its impossible to get this manual in internet. I hope this manual will help other people in future.

I love my Cambridge C500 amp, now it sound so sweet.
Attached Files
File Type: pdf ap105135caamplifiersusermanual-1357903624.pdf (789.1 KB, 147 views)
  Reply With Quote
Old 11th January 2013, 05:59 PM   #6
diyAudio Member
 
Join Date: Jan 2013
Talking Cambridge audio pre amplifier C500 andp500 user manual and schematic diagrams

Here is the user manual and service schematic diagram of Cambridge audio pre amplifier c500 and power amplifier p500. I have included schematic of A500 which is copy of p500 cheers guys
Attached Files
File Type: pdf ap105135caamplifiersusermanual-1357903624.pdf (789.1 KB, 128 views)
File Type: pdf P500.pdf (99.3 KB, 148 views)
  Reply With Quote
Old 12th January 2013, 06:53 PM   #7
Puffin is offline Puffin  United Kingdom
diyAudio Member
 
Join Date: Feb 2006
Location: U.K
Quote:
Originally Posted by wondipuli View Post
Hi Puffin
I did the same but there is no sound in speakers. Is it possible to hear the click sound of relay switch inside when switching on? i can see the green LED glowing
i followed the procedure from the image attached.
There are no relays in the P500.

The green LED means that there is mains voltage present. This does not mean that the amps will be working correctly. Do you know that these amps are capable of producing sound?

Have you checked that the tape monitor button is not connected? If so this would not allow the CD input to function.

Last edited by Puffin; 12th January 2013 at 06:59 PM.
  Reply With Quote
Old 12th January 2013, 07:03 PM   #8
RS232 is offline RS232  United Kingdom
diyAudio Member
 
Join Date: Jan 2006
Location: Swindon
Quote:
Originally Posted by wondipuli View Post
I love my Cambridge C500 amp, now it sound so sweet.
Does this answer your question ?
  Reply With Quote
Old 13th January 2013, 05:17 AM   #9
diyAudio Member
 
Join Date: Jan 2013
Hi Puffin
thanks for your support, I connected the amps with the help of user manual provided by cambridge audio customer support and also i tried as per your instruction. now the amp producing awesome music..................i love it.
  Reply With Quote
Old 19th January 2013, 08:35 PM   #10
diyAudio Member
 
Join Date: Jan 2013
Hi, does anyone have the C500 preamp circuit available?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cambridge Audio A500 & P500 Greghale3257 Solid State 33 30th April 2013 12:47 PM
Cambridge Audio p500 harwoodspark Solid State 1 12th December 2012 07:41 PM
Cambridge Audio C500 & P500 tom daghdha Solid State 5 12th November 2008 06:17 PM
Cambridge C500 Preamp lukecon Solid State 2 30th March 2006 08:37 PM
Cambridge p500 ostie01 Solid State 1 18th July 2005 08:52 AM


New To Site? Need Help?

All times are GMT. The time now is 10:35 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2