Panasonic SB WA520 modified to PC surround - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th January 2013, 06:56 PM   #1
diyAudio Member
 
Join Date: Mar 2006
Location: Australia
Lightbulb Panasonic SB WA520 modified to PC surround

I purchased a Panasonic surround system some time ago, without the controller module ie: DVD player etc, and just ended up with the Subwoofer and 5.1 surround speakers. I need to identify the connections on the plug that goes to the subwoofer and main amp, which supplies output to the speakers, .... SO that the output connections of a surround soundcard can interface with the input plug on the Subwoofer/Amp .... (CN501)

If someone with knowhow in this area can let me know what the connections are and mean and what to connect them to and what not to (or what is not necassary) that would be super gr8 !!

The connector code on the schematic is: CN501, and I need to get the 5.1 speakers connected, as well as the blue led 'on' light and remote switch 'on' and a mute button.

If anyone can help it would be much appreciated. I have had this sitting around for about 2 years new and not connected. I need to connect it to my new PC.


From what I can see on the schematic:

1.(1,25) "AC1" + (3,23) "AC2" must be + voltage;
2....while (9,10,13,16,18) "A GND" x 4 must be - voltage. (all are connected)
3....yet --- (6) "D GND" is not part of the 'ground connected hub'.
4.(7,22,24) "FL" must be 'front left'
5.(11) "FR" must be 'front right
6.(12) "SL" must be 'surround left'
7.(14) "SR" must be 'surround right"
8.(15) "C" must be 'centre'
9.(17) "SW" must be 'subwoofer'
10.(20) "mute av centre surround sync" appears to be some kind of 'mute surround' feature leaving only stereo?

I have no idea what:

■(2) "DC DET" is for ?
■(4) "8Y86V" is for?
■(5) "HP CNT" is for?
■(6) "D GND" is for?
■(8) "HELP" is for?
■(19) "PC CONT" is for?

(one must be for the 'on' led light ie: '8Y86V + D-GND?)

...if anyone can help would be appreciated...

I have attached the schematic: Thanks....
Attached Files
File Type: pdf sch1_2.pdf (153.9 KB, 83 views)
  Reply With Quote
Old 7th January 2013, 11:43 AM   #2
geminni is offline geminni  Yugoslavia
diyAudio Member
 
Join Date: Dec 2006
I have bought the same unit without controller or dvd player. I wast paying much attention on those voltages, they are probably for turning on and off and muting.
The first I did was removing all that digital on off switch thing in front transformer and connected it directly on ac, with analog switch of course
I have tested the pins and all the channels are working. But all are working full range, the crossover is in main unit so you will need to make one or not if you are connecting it to a computer with 5.1 output.

Mine is going to be connected with active crossover.
  Reply With Quote
Old 7th January 2013, 01:35 PM   #3
diyAudio Member
 
Join Date: Mar 2006
Location: Australia
Quote:
Originally Posted by geminni View Post
I have bought the same unit without controller or dvd player. I wast paying much attention on those voltages, they are probably for turning on and off and muting.
The first I did was removing all that digital on off switch thing in front transformer and connected it directly on ac, with analog switch of course
I have tested the pins and all the channels are working. But all are working full range, the crossover is in main unit so you will need to make one or not if you are connecting it to a computer with 5.1 output.

Mine is going to be connected with active crossover.
Thanks...

So exactly which of the 25 pins on the connector did you connect; and to where?
  Reply With Quote
Old 9th January 2013, 10:04 AM   #4
diyAudio Member
 
Join Date: Mar 2006
Location: Australia
Does anyone else have any idea ???
  Reply With Quote
Old 10th January 2013, 07:09 PM   #5
geminni is offline geminni  Yugoslavia
diyAudio Member
 
Join Date: Dec 2006
Here are the pins labeled.
The picture here is when you look from the back side. You can see print of a small "1" and "25". And you count pins according to a picture. I did not solder wires on pins because they are too close. I traced the lines to find the first pin of a 100 ohm resistor before input so I can have much more room for soldering.
Attached Images
File Type: jpg pinovi.jpg (80.0 KB, 134 views)
  Reply With Quote
Old 10th January 2013, 10:02 PM   #6
diyAudio Member
 
Join Date: Mar 2006
Location: Australia
Quote:
Originally Posted by geminni View Post
Here are the pins labeled.
The picture here is when you look from the back side. You can see print of a small "1" and "25". And you count pins according to a picture. I did not solder wires on pins because they are too close. I traced the lines to find the first pin of a 100 ohm resistor before input so I can have much more room for soldering.
Thanks for that. Its as I thought for those pins; so thanks for confirming that. At least that part is out of the way; ie: pins - 7, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18 : a total of 6 + and 5 - connections = 11 pins accounted for.
(in another schematic pin 6 is also connected to GND, giving 6+ & 6- = 12)

Now, the next questions are:

1. What is the pin 22 & 24 that says 'FL' mean? It appears to have something to do with the 'front left' channels (in service manual schematic is 'FL1' for pin 22, and 'FL2' for pin 24 - page 69)
2. pin 6 must be ground hub 'D-GND' (in service manual schematic is connected to GND also -page 69)
3. What is pin 20 'Mute AV Centre/Surround Sync' for (for stereo FC only?) (in 2nd schematic is labelled 'FREQ_HOP' - page 69)
4. What are pins 1 & 25 'AC1' for? (also called 'SUBAC1 & DVDAC1')
5. What are pins 3 & 23 'AC2' for? (also called 'SUBAC2 & DVDAC2')
6. What is pin 2 'DC DET' for? (DC detection for fan circuit?) *

* Posted: Wed Aug 10, 2005 7:33 am Post subject: HT 900

quote: -------------------------------------------------------------------------------

I am posting again to let you all know of a workaround. The problem here is that the circuit supplying current to the fan on thw subwoofer unit never turns on. As the fan circuit is monitored via the DCDET line, power output is limited in this state, and any attempt to get more power out of the unit trips the DCDET leading to power supply shutdown and F61 code.

I managed to get my unit working again by bypassing Q510 in the main subwoofer board from emmitter to collector with a 220 ohm 1/4w resistor. This switches Q508 which supplies current to the fan.

This all started because panasonic were concerned about fan noise and dreamed up this circuit to switch the fan on during louder passages of music! Unfortunately many people reported that their fan never came on.

Hope this will be of help to others in the same predicament as me. Pity that this good looking and sounding unit had a design flaw.

Victor : Need schematic Panasonic SC-HT900

unquote -----------------------------------------------------------------------------

7. Pin 4: 8Y86V or SYS6V appears to be LED light?? (or possibly 'temp detect'??)
8. Pin 5: HP CNT also has 'Mute H' label on other schematic (page 69)
9. Pin 8 has 'HELP' on one schematic, and 'SUB+B' for same pin on the other (page 69)
10. Pin 21: is labelled 'Sync' ??

Attached is a service manual: page 69 has another schematic of pin configuration/labels

http://diagramas.diagramasde.com/otr..._sa-ht520e.pdf

If anyone has any further input that would be gr8....

Last edited by TigerScent; 10th January 2013 at 10:25 PM.
  Reply With Quote
Old 10th January 2013, 10:58 PM   #7
diyAudio Member
 
Join Date: Mar 2006
Location: Australia
This schematic would explain a lot more:
Attached Files
File Type: pdf blkmain.pdf (28.7 KB, 50 views)

Last edited by TigerScent; 10th January 2013 at 11:03 PM.
  Reply With Quote
Old 10th January 2013, 11:36 PM   #8
diyAudio Member
 
Join Date: Mar 2006
Location: Australia
Going by the schematic: blkmain.pdf

DCDET indicates fan control
SYNC seems to be a power switch?
PCONT - seems to be involved with DCDET and fan control - how do they interface ?
SUBAC1 & SUBAC2 - seems to involve power supply?
FL1 & FL2 - seems to also involve power supply?

Can anyone confirm?
  Reply With Quote
Old 16th January 2013, 10:31 PM   #9
diyAudio Member
 
Join Date: Mar 2006
Location: Australia
...anyone have some knowledge of this; or a pretty good idea??
  Reply With Quote
Old 20th March 2013, 09:25 AM   #10
diyAudio Member
 
Join Date: Mar 2013
Hi TigerScent,

Did you have any success with this ? If I understand you correctly are you basically trying to get the panasonic connection to behave like a subwoofer jack?

I have tried hooking up to pin 17 & 18 and it's not having it :-( I wonder if there is some thing put on by design to prevent this working?

Is this a lost cause, do I need to bite the bullet and buy a new SW?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Panasonic SB-WA530 Subwoofer MarekMatuszczak Subwoofers 5 19th March 2013 09:27 AM
panasonic SB 400 speakers 60ndown Multi-Way 3 8th October 2012 01:32 AM
Panasonic-Thruster-Speakers-System-SB-180-8-ohm StevenOH Full Range 1 21st July 2008 08:59 PM
FS: Panasonic Thruster SB-300C somody Swap Meet 3 10th October 2005 03:17 PM


New To Site? Need Help?

All times are GMT. The time now is 07:43 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2