diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Solid State (http://www.diyaudio.com/forums/solid-state/)
-   -   Liquid discharge from capacitors? (http://www.diyaudio.com/forums/solid-state/222436-liquid-discharge-capacitors.html)

musicgold 29th October 2012 01:58 AM

Liquid discharge from capacitors?
 
4 Attachment(s)
Hi,

I have a subwoofer amplifier which has not been working. I checked its circuit and found four capacitors with a white liquid spilled at their bases. See attached files.

1. Will replacing those capacitors enough to get the amplifier working again?
2 What could have caused the liquid discharge and how can I avoid that in the future?
3. What is the best place to order these capacitors online?

Thanks.

wintermute 29th October 2012 02:04 AM

Hi musicgold, have a look at your camera and see if it has a macro function (often a picture of a flower) it will allow you to take close pictures without them being blurry.

It is difficult to tell from the photos, but what you are asking about may be glue rather than leakage from the capacitors. I've not seen electrolytics fail in that way before. A clearer picture including the bottom of the caps would be good.

The general reason for electrolytics to leak is either too high a voltage or exposure to high temps. If they are run too close to their voltage rating and too close to their temp rating, their lifetime will be dramatically reduced.

Tony.

Ian Finch 29th October 2012 02:22 AM

Nope, It's not really liquid any more, is it. It looks just like the adhesive used to keep these electrolytics safely on the board and not breaking off as the amplifier gets rough handling in transit and accidents.

Replace the glue when replacing the parts with any neutral cure silicone RTV, rather than that rubber building glue will be fine.

Regarding the replacement, It is unlikely that a failed amplifier can be fixed by swapping out (probably) good parts. You are guessing.

If you believe you could repair this and have instruments and suitable tools, we may be able to assist but you need to know basic electronics and how to use your gear first.

Why not start by refitting the caps, powering up and measuring any DC present across the output terminals. Assuming this is a class AB chip-amp, the voltage should be quite small, <50mV.

Ian Finch 29th October 2012 02:29 AM

OOPs! Sorry, no output terminals on a sub, It's the red and black wires to the speaker. Disconnect them and any input to the sub first.

theAnonymous1 29th October 2012 04:46 PM

1 Attachment(s)
I have one of these exact boards sitting in front of me right now. I've been meaning to throw the thing in the trash since it's been floating around my junk room for a few years.

You can have it if you want it.

jackinnj 29th October 2012 05:19 PM

Capacitor spooge.

lanchile 29th October 2012 06:10 PM

as it was mentioned before, that is just glue to give the "extra" hold for caps. I would just use an ESR meter to find out if those caps are dry out or not ;)


All times are GMT. The time now is 02:56 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2