crown xls 602 need help,no output - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th October 2012, 04:45 PM   #1
diyAudio Member
 
Join Date: Oct 2012
Smile crown xls 602 need help,no output

need help with a crown xls 602 amp, it comes on but not geting no outputs. you are geting the green led light in the front but no output on CH 1 or CH 2.i need help with this amp or its the bin for it,
  Reply With Quote
Old 16th October 2012, 05:37 PM   #2
diyAudio Member
 
zeonrider's Avatar
 
Join Date: Mar 2004
Location: Belgrade RS
Check the two flat cables:

Click the image to open in full size.

Regards zeoN_Rider
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crown XLS 602 MaitreG Solid State 41 23rd April 2013 05:33 PM
Crown 602 XLS Power Issue msquicc Solid State 10 14th June 2011 10:51 AM
Crown XLS 602 service manual stevep314 Solid State 4 25th April 2010 10:02 PM
crown xls 602 galush Parts 1 4th June 2009 01:40 PM
crown xls 602 amp galush Solid State 0 6th April 2009 04:41 PM


New To Site? Need Help?

All times are GMT. The time now is 09:22 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2