Schematic needed for Focal 2.150 LE car amplifier - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th October 2012, 10:01 PM   #1
diyAudio Member
 
Join Date: Jul 2010
Default Schematic needed for Focal 2.150 LE car amplifier

Hi
I just put to reuse my Focal 2.150 LE car amplifier.

Its one channel is clipping pretty badly, other works like a charm.

I have spent over 50 Hrs trying to locate the fault and redraw the schematic but the problem has not been solved. i have partially decoded the schematic but i think i need pretty experienced advice to help solve the clipping problem.

The Vbe is working fine feeding a darlington TIP 102/107 which in turn drives a pair of TIP 35/36c help needed.
regards
  Reply With Quote
Old 7th October 2012, 10:18 PM   #2
diyAudio Member
 
Join Date: Jul 2010
bump. help requested.
  Reply With Quote
Old 7th October 2012, 10:36 PM   #3
diyAudio Member
 
Join Date: Feb 2010
> car audio subforum
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
increasing power of Focal car amplifier muddasirwaheedmalik Car Audio 5 19th June 2012 02:27 PM
Punch 150 schematic needed brandes.cm Car Audio 34 23rd October 2011 03:01 AM
capacitor upgrade for Focal 2.150 amplifier muddasirwaheedmalik Solid State 0 23rd August 2011 09:12 PM
schematic needed for levinson PLS-150 power supply james559 Power Supplies 0 7th February 2005 02:31 PM
Threshold S/150 manual/schematic needed lpd Solid State 2 22nd December 2003 02:38 AM


New To Site? Need Help?

All times are GMT. The time now is 10:10 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2