Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

DB HPA 3100L Power Amp
DB HPA 3100L Power Amp
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd October 2012, 12:18 PM   #1
Carlosraj is offline Carlosraj  United Kingdom
diyAudio Member
 
Join Date: Jan 2010
Default DB HPA 3100L Power Amp

Dear Friends

I am trying to help fix a db technologies HPA 3100L power amp belonging to a friend of mine. This is a new amp and rated as class HD. When the amp is turned ON, it keeps going into protect mode, There is no input signal connected and totally no speakers connected (no load). I turned the amp ON, the volume is totally off. After sometime, the protect LED comes on, then after sometime it turns off. It keeps repeating this same thing. I realise that the amp gets very HOT, but all the cooling fans are working. I am surprised that the amp is still new and without any signal or load, the is going into protect. Can anyone please help.

Thanks

Carlos
  Reply With Quote
Old 3rd October 2012, 12:01 AM   #2
Old'n'Cranky is offline Old'n'Cranky  Australia
diyAudio Member
 
Join Date: Aug 2009
Quote:
Originally Posted by Carlosraj View Post
This is a new amp
the amp is still new
and without any signal or load, the is going into protect.
Um pardon me, but if it's new, why not send it back for warranty ?
  Reply With Quote

Reply


DB HPA 3100L Power AmpHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Audax PR170M0 100 dB or just *94 dB?? rick57 Multi-Way 44 22nd December 2013 12:50 AM
HPA-nxV300 & HPA-nxV300se what's the difference? pcsl999 Aussie Amplifiers 14 3rd September 2013 10:24 PM
LP & HP filter for HPA-nxV203PS pcsl999 Aussie Amplifiers 2 24th February 2010 09:04 PM
116 db peak db how loud is that 8cube Multi-Way 21 8th November 2007 06:45 AM
Coverting dB/2.83w to dB/1w moving_electron Multi-Way 27 9th March 2004 02:47 PM


New To Site? Need Help?

All times are GMT. The time now is 11:44 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki