Sansui BA-2000 Powers On But No Sound - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th September 2012, 04:55 PM   #1
diyAudio Member
 
Join Date: Sep 2012
Location: Sycamore Illinois
Default Sansui BA-2000 Powers On But No Sound

Hello i have an old Sansui BA 2000 Power Amp that i have owned since i purchased it 33 years ago in Okinawa when i was serving in the Marines it has been an awesome amp but recently it has stopped working but when i do try to use it-it will power on in its usual manner and by that- i will flip the switch and the LED indicater will turn red then 4 or 5 seconds later turn green and this has always been the norm since it was first purchased exept now it will not put out any sound/power to the speakers not even a pop,click or any sound what so ever just total perfect silence and even the meters that will usually move just a hair when the LED turns green-nothing at all and i am curious if there is somthing that i can handle to fix it or will i end up taking it somewhere to be looked at by a tech. Now i have been inside and have checked all the internal fuses and they all check out to be O.K.
  Reply With Quote
Old 30th September 2012, 05:12 PM   #2
diyAudio Member
 
Join Date: May 2008
I would check the speaker protection/delay relay circuit.
If you are lucky, it is only a dried-out electrolytic capacitor in the delay circuit.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
F.S: Sansui BA-3000 parts Cobra2 Swap Meet 3 3rd December 2012 09:29 AM
Sansui BA-303 CrewBies Tubes / Valves 8 7th January 2012 11:43 PM
Sansui BA-5000 Oscillation EchoWars Solid State 48 12th June 2009 12:36 AM
Faulty Sansui BA-F1 could use some help Netlist Solid State 26 16th February 2008 09:45 PM


New To Site? Need Help?

All times are GMT. The time now is 07:19 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2