Harrison X150 Mosfet Amp - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th July 2012, 04:23 PM   #1
diyAudio Member
 
Join Date: Dec 2011
Smile Harrison X150 Mosfet Amp

Hi,

Not a frequent poster here but hope someone can help.

I bought an old Harrison X150 amp a couple of months back from Ebay and after a few minor repairs (replaced volume pot and mains switch) it was
up and running, sounding remarkably good for a 27 year old amplifier. In case i ever needed to do a more complex repair, i trawled the internet looking for a circuit diagram and managed to find lots of references to HH Electronics VX-150 schematic which looked very similar to the X150 (i know about the history of Harrison, HH and Laney). In the meantime, another X150 came up on Ebay and i snapped it up with a view to having a spare or experimenting with bi-amping etc. The second X150 looked identical except the Plug-in modules on the back panel were recessed.
I did all the basic power-on tests before plugging it into my system. First thing i noticed, the output volume even at maximum level was very low. Removed the lid and was surprised to see totally different internal electronics from the first X150. Clearly, a later revision but without the two VCA plug-in modules which the first unit has. That probably explains the lack of volume? I dont suppose anyone out there has a circuit diagram that includes the VCA module or a couple of spare VCA modules lying around? i have posted pics to help identify. Ta
Attached Images
File Type: jpg First_X150.jpg (990.3 KB, 153 views)
File Type: jpg Plugin_VCA.jpg (971.2 KB, 123 views)
File Type: jpg Second_X150.jpg (1.03 MB, 116 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Harrison k 3000 power amp AA1987RON Everything Else 2 4th October 2012 11:48 AM
Harrison 24 IC options Fezzle Chip Amps 0 8th December 2011 09:53 AM
Harrison XI600 TroelsM Solid State 12 7th July 2010 08:28 AM
Harrison Power Amplifiers Aug Solid State 9 24th March 2010 06:14 PM
X150 produces a "Pop" during power down kmtkwong Pass Labs 5 18th April 2008 04:04 AM


New To Site? Need Help?

All times are GMT. The time now is 09:42 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2