Popping Crate GX-130C - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th July 2012, 01:26 PM   #1
diyAudio Member
 
Join Date: Jul 2012
Default Popping Crate GX-130C

Hi! I have a Crate GX-130C combo that pops quite loudly after it's been on for a few minutes. I see the channels switch on their own when it pops as well.

Any idea's, or suggestions? I'm quite handy with a soldering iron.

THANKS!
  Reply With Quote
Old 6th July 2012, 03:00 PM   #2
diyAudio Member
 
Osvaldo de Banfield's Avatar
 
Join Date: Dec 2011
Location: Barrio Garay,Almirante Brown, Buenos Aires, Argentina
At first, change the electrolytic caps. One or more of them may be faulty, leaky or degraded. More important are coupling caps, and power supply ones.
__________________
LW1DSE
  Reply With Quote
Old 6th July 2012, 05:40 PM   #3
diyAudio Member
 
Join Date: Jul 2012
would that be all the electrolytics on both the pre and power amp board?

Now that I've asked that question, here's another.....

I left the thing on, and noticed that the chorus section kicks in intermittently. I wonder if that has anything to do with this as well....

Granted I got this thing CHEAP (40 bucks) but I'm beginning to wonder if it's worth all the time/materials to mess with it...
  Reply With Quote
Old 6th July 2012, 06:31 PM   #4
diyAudio Member
 
Osvaldo de Banfield's Avatar
 
Join Date: Dec 2011
Location: Barrio Garay,Almirante Brown, Buenos Aires, Argentina
Quote:
Originally Posted by MemphisMerv View Post
would that be all the electrolytics on both the pre and power amp board?
I always replace electrolytics by a group of 5, no more with a switch on between any group. So if you do a mistake, are sure that it is in the last group.

Quote:
Now that I've asked that question, here's another.....

I left the thing on, and noticed that the chorus section kicks in intermittently. I wonder if that has anything to do with this as well....
Surely. coupling caps with leakage may have erratic job.

Quote:
Granted I got this thing CHEAP (40 bucks) but I'm beginning to wonder if it's worth all the time/materials to mess with it...
__________________
LW1DSE
  Reply With Quote
Old 7th July 2012, 12:12 AM   #5
diyAudio Member
 
Join Date: Apr 2010
Location: Coffs Harbour
Quote:
Originally Posted by MemphisMerv View Post
Hi! I have a Crate GX-130C combo that pops quite loudly after it's been on for a few minutes. I see the channels switch on their own when it pops as well....
It seems a bit more than the usual problem with old caps. It is throwing logic controlled switches so there is likely quite a disturbance on the low level supply rails.

'Need a schematic, I'm afraid. Meantime, scope the preamp and main power rails if you can, to see if there is something going on there.

However, this might be interesting regarding connectors too.
__________________
Ian
  Reply With Quote
Old 15th August 2014, 02:00 PM   #6
diyAudio Member
 
Join Date: Aug 2014
Location: St. Catharines, Ontario
Is anyone still following this thread?
I was given this Crate amp and love the chorus, so creamy.
Unfortunately I originally only got the bare chassis. I now have the rest but the reverb is disconnected.
I need to find which spade lugs to reconnect the reverb to.
I have seen photos online but all have been to blurred to tell which connection to use.If anyone could take a photo of the connections I would appreciate it
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Akai GX-95 Mikewong Analogue Source 25 23rd June 2013 01:21 AM
Orion 280 gx mike49504 Car Audio 10 31st January 2010 05:24 AM
Crate GX-80 Bad Input achipola Instruments and Amps 0 2nd November 2008 11:48 PM
Akai gx f-31 Iagent Everything Else 0 2nd November 2007 08:30 PM


New To Site? Need Help?

All times are GMT. The time now is 05:46 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2