Sumo andromeda series 3 with bad channel - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th July 2012, 11:14 AM   #1
srinath is offline srinath  United States
diyAudio Member
 
Join Date: Feb 2010
Default Sumo andromeda series 3 with bad channel

The amp when you power it on and hasn't got input, it makes a sorta hiss/static through its speakers, its in both but louder on the left.
Then when you put in an input, the left is very weak compared to the right.
This is a cap coupled output amp, could the output caps be at issue ?
Is there a filtering cap, and could it have given up ?
Where can I find a schematic for it ?

Thanks to all.
Srinath.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sumo Andromeda III Settings johnsciolino Solid State 17 26th January 2013 01:57 PM
Sumo Andromeda very early series schematics musinteg Solid State 5 17th June 2011 06:00 PM
Sumo Andromeda restoration weinstro Solid State 0 11th April 2009 06:04 AM
Sumo Andromeda mods ben12345 Solid State 1 18th February 2009 05:50 AM
FS SUMO Andromeda for parts woody Swap Meet 1 22nd April 2008 12:00 PM


New To Site? Need Help?

All times are GMT. The time now is 10:13 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2