Kenwood KA-907 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd July 2012, 04:32 PM   #1
LouLips is offline LouLips  United States
diyAudio Member
 
Join Date: Jul 2012
Thumbs up Kenwood KA-907

Hello All;

I recapped a working Kenwood KA-907 this past weekend.

I plugged it in, waited for the protection circuit to to click... and yes it clicked on! I left the amp on for a while.

After an hour or so, it un-clicked. I powered it down, then up. It clicked on after 5 minutes. Turned it off overnight and it wont clck on again.

This is my first re-cap and could use your advice to troubleshoot the issue.

Thank you all in advance.

LouLips
  Reply With Quote
Old 2nd July 2012, 05:49 PM   #2
johnr66 is offline johnr66  United States
diyAudio Member
 
Join Date: Mar 2009
What was the condition of the amp before recapping?
Are you sure you got the polarities right? I've seen some old caps that marked the positive lead and that can throw people off.
  Reply With Quote
Old 2nd July 2012, 07:05 PM   #3
LouLips is offline LouLips  United States
diyAudio Member
 
Join Date: Jul 2012
It worked adequately. FWIW the inside had much residue from a smoker, but the cosmetics are good so it made a good candidate for recap.

Any other areas you can think of for initial inspection?

Thanks for the heads up!

LL
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: TRIO Kenwood KA-907 total audiophile Swap Meet 3 19th January 2012 03:36 PM
A mint Kenwood KA-907 amp is arriving, I need help/info/advice on restoring it. Kuja Solid State 5 21st November 2011 11:46 PM
Kenwood KA-2600 adason Solid State 11 31st August 2010 12:25 PM
Help with Kenwood KA-94 lumstar Solid State 0 7th January 2009 12:31 AM
Kenwood KA-5040R Briek Solid State 2 4th March 2007 08:54 AM


New To Site? Need Help?

All times are GMT. The time now is 02:26 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2