old amp need some help - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th June 2012, 07:49 PM   #1
diyAudio Member
 
Join Date: Jun 2012
Default old amp need some help

Hi I have a old Majestic MA 790C 300 Watts and it has blown some thing it goes from the remote turn on to some thing can I just jump it or what I would like to put what ever is in there from the factory thanks
  Reply With Quote
Old 21st June 2012, 08:35 AM   #2
Bone is offline Bone  United Kingdom
diyAudio Member
 
Join Date: Jun 2004
Location: Dorset, UK
Can you give a better explanation please?
  Reply With Quote
Old 22nd June 2012, 01:51 AM   #3
diyAudio Member
 
Join Date: Jun 2012
what more do you want to know?
  Reply With Quote
Old 22nd June 2012, 02:45 AM   #4
diyAudio Member
 
jordheis's Avatar
 
Join Date: Jan 2011
Location: Minnesota, USA
Default punctuation helps. move to car audio forum?

"Hi
I have a old Majestic MA 790C. 300 Watts and it has blown some thing.
It goes from the remote turn on to some thing. Can I just jump it or what? I would like to put what ever is in there from the factory.
Thanks"

Hi. You want to make the car's audio back to OEM and bypass the blown Majestic?
__________________
I'm a Groove Puppy
Striving to remove some ignorance every day (always starting with my own)
  Reply With Quote
Old 22nd June 2012, 04:12 AM   #5
diyAudio Member
 
Join Date: Jun 2012
I have never installed the amp I was going to try and fix it and use it to power a sub a friend gave it to me a couple of years ago and I just now have had the chance to play with it
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FS- Twisted Pear Buffalo 32S Board & System New & Unused secretriches Swap Meet 1 10th August 2009 02:17 PM
Modify & build out (2) Western Electric 300B / 2A3 Hammond monoblock amps & UTC LS-5 quality sound Tubes / Valves 0 9th May 2009 03:59 PM
Krell KSA 80 bias & dc offset check & adjust procedure Clouseaupte Solid State 3 9th August 2007 09:39 AM
DIY-AMP <ZAS> Low THD & IM high bandwith murphy Solid State 18 30th December 2005 10:28 AM


New To Site? Need Help?

All times are GMT. The time now is 05:55 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2