carver m1.5t ground hum - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th June 2012, 02:07 PM   #1
srinath is offline srinath  United States
diyAudio Member
 
Join Date: Feb 2010
Default carver m1.5t ground hum

I got a dead m1.5t which makes a ground hum on the left channel which is independent of volume, and the right makes sound that is mixed with a lot of ground hum noise and that does go up and down with volume - from the pre-amp.
Anyone has experienced this ? or has a direction to point me to.
Thanks.
Srinath.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Carver m1.5t (Attn: Anatech) oldsthunder Solid State 36 14th June 2012 03:29 AM
Carver M1.5T Amp issue john65b Solid State 15 2nd February 2012 07:57 PM
carver m1.5t joepro Solid State 4 22nd January 2007 07:30 AM
Help with Carver M1.5t oldsthunder Solid State 2 22nd June 2006 02:02 AM
Carver M1.5t Transistors jeffgilb Parts 1 15th August 2005 03:22 PM


New To Site? Need Help?

All times are GMT. The time now is 05:57 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2