QUAD 405 main board fuse blow - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 18th June 2012, 05:31 PM   #1
ClassA is offline ClassA  Taiwan
diyAudio Member
Join Date: Nov 2005
Location: Taiwan
Default QUAD 405 main board fuse blow

My 405(1978 version) main board (one side) fuse blew when power is on. Anyone knows what happened?

  Reply With Quote
Old 18th June 2012, 05:48 PM   #2
diyAudio Member
tiefbassuebertr's Avatar
Join Date: Jul 2005
Location: D-55629 Schwarzerden
Originally Posted by ClassA View Post
My 405(1978 version) main board (one side) fuse blew when power is on. Anyone knows what happened?

Check out the power output devices Tr9 and Tr10 so as the driver transistor Tr8/Tr7 - go to
Check out additional, whether the micas between the heatsink and the transistors are in good condition.
In case of failured BDY77 check the power amp in first step without Tr8-10 (i. e. only with Tr7, R30 and R31 - now only working as a single ended power amp with aprox. 20mW output power - i. e. very small output level, but enough for hearing).
After proper working in this mode you can risk the replace of the output power devices.
  Reply With Quote


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
quad 405-2 fuse blower Douglas M Solid State 7 1st May 2011 10:37 PM
Main fuse blow on Classe DR8 Simbab Solid State 1 21st August 2010 10:44 PM
Why main fuse and not rail fuse? digital desire Solid State 10 3rd December 2006 09:07 PM
Quad 44 main board opamps...question Zombie Solid State 0 24th September 2003 08:31 AM

New To Site? Need Help?

All times are GMT. The time now is 07:31 AM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2