Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Sherwood RV-8070R
Sherwood RV-8070R
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 11th June 2012, 12:21 PM   #1
Carlosraj is offline Carlosraj  United Kingdom
diyAudio Member
Join Date: Jan 2010
Default Sherwood RV-8070R

Hi Friends,

I am having a problem fixing a sherwood RV-8070R AV amplifier. There is no sound from both the A and B Front Speakers. The centre speaker and rear speakers are working fine. I opened up the output board and found that all the output and driver transistors are OK.The front display is working fine. I can see only one relay which is meant for switching the power supply. The front, centre and rear speakers do not have any relay. Are the front speakers switch on by the microcontroller. Pls help.

  Reply With Quote
Old 30th May 2014, 06:53 AM   #2
joaomsilva is offline joaomsilva
diyAudio Member
Join Date: May 2014
Default Sherwood RV-8070R


I'm having the exact same issue. Did you manage to sort it out in the end?
  Reply With Quote


Sherwood RV-8070RHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting Sherwood RV-6010R surround reciever PSU AMelbye Power Supplies 1 1st April 2017 09:36 AM
Luxman Av Receiver Rv-357 elec972 Solid State 1 26th October 2015 03:37 PM
camper/RV hifi F.A.S.T Tachyon Multi-Way 2 6th June 2012 01:39 PM
Sherwood rv-8070r transistor help (sanken) sketchone Chip Amps 2 30th May 2011 04:43 PM
! Schematic needed ! for Sherwood rv-5050rds Brage Parts 0 18th February 2005 12:59 AM

New To Site? Need Help?

All times are GMT. The time now is 09:40 PM.

Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio