Hafler DH-200 Dead Channel - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st May 2012, 09:40 AM   #1
diyAudio Member
 
Join Date: May 2012
Default Hafler DH-200 Dead Channel

Just acquired Hafler DH-200 power amplifier. One channel is dead. The heatsink on that channel is very hot as are the 4 output transistors. Any suggestions?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
hafler dh-200 rebuild BrianGT Solid State 65 22nd May 2013 02:49 AM
Hafler DH-200 problems... bigbargain Solid State 4 29th February 2012 03:07 PM
Mixing Hafler Dh-220 with DH-200 MixedBag Solid State 0 31st October 2007 01:20 PM
Refreshing a DH-200 Hafler jakelm3075 Solid State 10 10th August 2007 01:39 PM
Noisy Channel in Hafler DH-200 neddyboy Solid State 9 15th September 2006 03:58 PM


New To Site? Need Help?

All times are GMT. The time now is 01:32 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2