dc filter - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th January 2002, 01:36 PM   #1
diyAudio Member
 
wuffwaff's Avatar
 
Join Date: Aug 2001
Location: Ingolstadt Germany
Question dc filter

Hello,


Ive got a question concerning a "DC-Filter" offered by LC-Audio. Its supposed to remove dc from the mains and reduce transformer noise.

Does anybody know how this works?

william
  Reply With Quote
Old 25th January 2002, 06:31 PM   #2
The one and only
 
Nelson Pass's Avatar
 
Join Date: Mar 2001
If you are experiencing mechanical hum from your
transformer, it is often caused by the presence of
DC on the line. Usually this comes from some appliance
using current asymmetrically, such as a lamp dimmer.

The hum comes usually from toroidal transformers, which
saturate easily with DC, and when they recover, they
draw an extra pulse of current, causing the noise.

You can put a pair of back-to-back electrolytics in series
with the AC power line to block this, and it works fine.
Makes sure the current rating of the electrolytics is
high enough, and the they are joined at a like polarity,
such as + to +.
  Reply With Quote
Old 25th January 2002, 06:45 PM   #3
diyAudio Member
 
Join Date: Oct 2001
I'm wondering how the back-to-back electrolytic capacitors will behave during a fault condition such as a short circuit. What I'm trying to say is that the capacitors could limit the current and thus prevent the fuse to trip which may lead to dangerous situations.
  Reply With Quote
Old 25th January 2002, 08:09 PM   #4
diyAudio Member
 
Join Date: Feb 2001
Location: Columbia, SC
Note also that transformers can hum if they get heavily loaded.
I've got a fairly large EI transformer that I picked up cheap once upon a time. It hums. Turned out that one of the laminations had a tab sticking off to one side that wasn't held firmly against the previous lamination (right in the middle of one side, away from the screws that hold the thing together). The flux made it vibrate against the rest of the transformer. I slid a piece of paper between the laminations and the hum stopped completely.
One of these days I'll get out some shellac and do a proper job of fastening that little fella down...

Grey
  Reply With Quote
Old 25th January 2002, 09:11 PM   #5
diyAudio Member
 
wuffwaff's Avatar
 
Join Date: Aug 2001
Location: Ingolstadt Germany
thanks for the replies!

In my case I think it is DC causing the hum. Its not always the same but about a month or two ago it has become louder as before and can be heard when all is silent. (and gets very very loud when somebody uses a hairdryer)

Any suggestions for a specific type of capacitor? I assume they need a 400V rating (230v mains) but Im not sure what capacity will be sufficient.

william
  Reply With Quote
Old 25th January 2002, 09:52 PM   #6
diyAudio Member
 
wuffwaff's Avatar
 
Join Date: Aug 2001
Location: Ingolstadt Germany
oh and I almost forgot,

the LC audio filter seems to have only one 22000microF /25V cap, a diode and a fuse.

must be another way of blocking or removing a dc component?

william
  Reply With Quote
Old 25th January 2002, 11:27 PM   #7
diyAudio Member
 
Join Date: Oct 2001
Location: Melbourne, Australia
William,

In Australia, we have three phase powerlines. Every third house is connected to the same phase to preserve a balanced power drain. You could request your power supply company or utility to change the phase to your house.

I use electrostatic speakers and valve amps at home. I had similar problems and I suspected DC on the powerlines. The power utility company changed the phase to my house and the hum disppeared.

I would imagine that the density of appliances connected to each phase would be a great deal higher in Germany than in Australia and so perhaps this suggestion may not be applicable. Nelson's suggestion is a good one.

Mohan
  Reply With Quote
Old 25th January 2002, 11:30 PM   #8
subwo1 is offline subwo1  United States
diyAudio Member
 
subwo1's Avatar
 
Join Date: Jan 2002
Location: North American Continent
It seems like they put the diode across the capacitor so that it can only charge in one direction. That would be the direction from which the dc is trying to get through. So, if it doesn't solve the problem hooked up one way, my guess is that you would have to reverse it.

The 25 volt rating assumes that the impedance of the load, say a transformer is much less at 60hz than the load. Xsubc = 1 / 2*pi*f*c. Xsubc, the impedance of the capacitor comes out to be .12ohm. I guess this process is what is going on.
  Reply With Quote
Old 26th January 2002, 01:49 AM   #9
diyAudio Member
 
Join Date: Jan 2002
Location: California
I had that problem with a large toroid at one time (intermittent humming)... you might want to try reversing the polarity of the primary winding -- this seemed to fix my problem completely. Also, unbalanced load on the secondary can cause hum on some toroids. This could occur if your protection relays or other circuits are powered only from the + or - rail and not both rails evenly. Hope this helps!!
  Reply With Quote
Old 26th January 2002, 02:08 AM   #10
subwo1 is offline subwo1  United States
diyAudio Member
 
subwo1's Avatar
 
Join Date: Jan 2002
Location: North American Continent
"The 25 volt rating assumes that the impedance of the load, say a transformer is much less at 60hz than the load."

I meant to say the 25 volt rating assumes that the impedance of the load, say a transformer is much more at 60hz than the capacitor.

Sorry for any confusion. Take care all.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
need help wana change 60-Hz twin-T notch filter to 279 Hz filter prorms Solid State 0 9th February 2008 11:38 PM
Can Zaphs notch filter be used without the BSC filter? GuyPanico Full Range 0 21st July 2007 01:27 AM
Just one big filter cap or more smaller filter caps ... beppe61 Power Supplies 2 18th July 2006 05:46 PM
active filter from rod elliot and sub filter questions wuffer Parts 0 2nd October 2005 01:12 PM
chassis-mounted filter or IEC plug filter jarthel Solid State 7 11th March 2002 10:17 AM


New To Site? Need Help?

All times are GMT. The time now is 06:55 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2