Electrocompaniet AW-100DM - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th September 2003, 09:27 AM   #1
ManUtd is offline ManUtd  Norway
diyAudio Member
 
ManUtd's Avatar
 
Join Date: Sep 2003
Location: Hof,Norway with Nice Mountains!
Question Electrocompaniet AW-100DM

Hi to all.
I`m new to this board,but would like to get all info about a Good old Norwegian Amp. named Electrocompaniet AW-100DM.
After i got it for 100$!! and tried it for some days,i would like to improve it a little.It do not have any timeswitch for speakers
when powered on.Softstart ? (Sometimes fuses blows when powered on).
Any good scematic i can use for this purpose?
Also if anyone has a scematic for this old amp?(Most Important)

Regards,
New Member today,

Bjorn
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello from an Electrocompaniet Fan PrimeCase Introductions 10 25th September 2012 02:17 PM
Electrocompaniet AW-100DM ManUtd Solid State 17 1st November 2008 12:43 AM
Electrocompaniet Help Andypairo Solid State 66 9th July 2008 11:13 AM
Electrocompaniet AW 250 AMP. hogue Solid State 1 1st March 2004 06:48 AM


New To Site? Need Help?

All times are GMT. The time now is 03:32 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2