Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Adcom GFA 555 not putting out much watts
Adcom GFA 555 not putting out much watts
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st February 2012, 12:59 AM   #1
tloftis is offline tloftis
diyAudio Member
 
Join Date: Feb 2012
Default Adcom GFA 555 not putting out much watts

my adcom seems to be putting out around 50 watts max. and I know that is not right. My onkyo 100 watt will blow it away. tried many speakers. anyone know what might be wrong with it? I am on a budget and would like to repair it myself with some help from you guys
  Reply With Quote

Reply


Adcom GFA 555 not putting out much wattsHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Adcom gfa 555 help 406vette Solid State 34 15th October 2011 03:34 PM
Adcom GFA-555 eelekim Pass Labs 2 14th May 2009 03:42 PM
Adcom GFA-555 claiborne Solid State 8 27th September 2007 10:20 AM
FS:Adcom GFA 555 and GFA 5300 trusound Swap Meet 0 13th December 2005 05:06 PM


New To Site? Need Help?

All times are GMT. The time now is 07:43 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki