Newbie troubleshooting DEAD amplifier! - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th January 2012, 02:44 PM   #1
Bosher is offline Bosher  United Kingdom
diyAudio Member
 
Join Date: Jan 2012
Default Newbie troubleshooting DEAD amplifier!

Hi there, i have a Yamaha AX-500 amplifier which has blown. The reason it blew was probably because i had a large amount of speakers connected to it and the volume pretty high and must have overheated due to strain or something.
It is completely dead, when i press the switch on nothing happens. I've opened it up an check the fuses and they were both still intact. I now have no idea what to do now in terms of determining what the fault is.
As i've said, electronics is all new to me so i would need a step by step explanation which would be very helpful indeed!

I have a multimeter that i've been using, however im not getting any values anywhere, apart from resistance values. Am i supposed to plug in the amplifier and test it like that? Or is that dangerous?

The transformer doesn't look like it is broken, no soot or black stuff around it.

If anybody has any tips on where to start i would be very grateful! This amp is about 5-10 years old and i want to try and fix it myself rather than take it to an electronics shop.

Many thanks
  Reply With Quote
Old 14th January 2012, 03:59 PM   #2
49 - for the 18th time
diyAudio Member
 
c2cthomas's Avatar
 
Join Date: Oct 2006
Location: Near "Music City" (Nashville Tennessee)
Quote:
Originally Posted by Bosher View Post

i want to try and fix it myself rather than take it to an electronics shop.

Many thanks
DON'T EVEN THINK ABOUT IT - WITHOUT ANY KNOWLEDGE OF ELECTRONICS YOU MAY INJURE OR EVEN KILL YOURSELF - AND I'M NOT KIDDING!!!!

PLEASE - STOP WHAT YOU ARE DOING AND KEEP YOUR HANDS OUT OF THAT AMP!!!

We can get you started learning electronics - if you want to spend a few months reading and studying the subject - and there are many of us here that can help you. In fact - that is exactly what I am doing by telling you to keep your mitts out of that amp until you know at least some basic electronics.

The 1st rule of electronics - safety 1st!!!!!!!!

Really - what you are doing is looking down the barrel of a loaded gun!!
__________________
DIY audio can be expensive but getting to see things go up in smoke - that's priceless!!!! ..... "whatever - call it brainfart of Mighty ZM"
  Reply With Quote
Old 14th January 2012, 04:08 PM   #3
DF96 is offline DF96  England
diyAudio Member
 
Join Date: May 2007
Quote:
Originally Posted by Bosher
I have a multimeter that i've been using, however im not getting any values anywhere, apart from resistance values. Am i supposed to plug in the amplifier and test it like that? Or is that dangerous?
With that level of electronics knowledge yes it would be dangerous. Find a friend who knows about electronics, take it to a shop, or spend months/years reading up and experimenting with simple battery-powered circuits until you know enough. Your choice.
  Reply With Quote
Old 14th January 2012, 05:27 PM   #4
diyAudio Member
 
lanchile's Avatar
 
Join Date: Sep 2008
Location: AREA 51
With your knowledge in electronics...I would leave it to someone else!.
it is very dangerous to "play" around high voltages.The problem can be the toasted outputs transistors , resistors or many others parts. for that you have to know at least how to read a transistor with an ohmmeter, trace voltages etc. for what I read you do not know how to read a transistor so you will not know if the transistor is good or bad. just leave it to someone else and avoid problems and a huge shock!!
  Reply With Quote
Old 14th January 2012, 06:41 PM   #5
Jebem is offline Jebem  Portugal
diyAudio Member
 
Jebem's Avatar
 
Join Date: Dec 2011
Location: Lisbon
Bosher,
Whatever you do, do not peek inside with the amp plugged to the mains supply! It is really dangerous.
And if you did it, unplug it and what 1 hour to make sure the power supply capacitors are discharged (those 2 big ones C219 and C220 12000uF / 65Volt each).

Then if you feel like doing some troubleshooting, do the following (but do not plug the amp to the mains):

Step Zero: Check your multimeter. Switch it on. Select Ohms scale, low value (x1 or else, auto, depending on the model). With the two probes in free air, read the value: this is your infinite resistance reading. Now put the two probes in contact: this is your short circuit reading value.

Now on the amp (again, do not plug the amp to the mains):

1. press the power on switch.

2. use your multimeter in ohms scale (select the low scale x1 if it is an old model), and put the two probes on the mains cable plug pins, each probe to each pin (do not touch the pins with your fingers).

3. read the resistance value.
You should get a low value, like between 10 and 100 ohms. If you do, then the problem is elsewhere. The fuse is ok.

4. If the reading is 0 or 1 ohm, it will be very rare indeed, but it can happens, it means that your transformer can be in short circuit (bad news, you need a new one).

5. If the reading is infinite (on analog meters) / 0L (on digital meters) resistance, you have found one problem to fix (but the amp can ahve more problems to fix...).
In this case, you have a problem on one or more of these components:
- the fuse;
- the power switch
- the power cable
So using the multimeter, it is really simple to find out which component is faulty:
5.1. Just put the probes on the fuse terminals. You should get a short circuit value; if not, replace the fuse.
5.2. Put the probes on the switch terminals. Again, if the switch is ON and you do not get a short circuit, it means that you need to replace it.
5.3. Check the two cable leads. Put one probe between one pin of the mains power cable plug and the other probe on the other end of the power cable. Because you don't know what end corresponds to the pin you are checking, you need to probe both cable leads; at least one reading shoyld give you a short.

Good luck on your electronics learning, and please be careful. Electricity can kill (that is what I have learned at my technical school days anyway).

Jose
__________________
If You need something done properly, do it yourself (and ask help from DIYaudio... )
One of my SE 211 tube amps: http://sites.google.com/site/sunajeb...ificador-211se
  Reply With Quote
Old 15th January 2012, 12:19 AM   #6
jaycee is offline jaycee  United Kingdom
diyAudio Member
 
Join Date: Apr 2004
Location: Norwich, UK
I guarantee you have fried the amp beyond economical repair. If there is "no power anywhere" you have probably melted a thermal fuse in the main power transformer. This is not replaceable and it is unlikely you will be able to replace the transformer.

You have no experience with repairing electronics, so at best your attempting to do so will be fruitless, at worst you will kill yourself with the dangerous voltages present.
  Reply With Quote
Old 15th January 2012, 12:42 AM   #7
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
I have been in electronics 33 years and I am still not an expert on fixing amplifiers.
Amplifiers arent always easy to fix either, sometimes you can get multiple component failures. Changing one failure can just kill the component you just replaced. Also an amplifier is a loop so its sometimes hard to decide where in the loop it is going wrong.

Buy another one or get this one fixed by someone who knows what they are doing.
After all you are a long time dead !!!!
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LM3886 troubleshooting help needed for newbie franke Chip Amps 14 3rd January 2012 04:59 PM
newbie Q on troubleshooting esc Chip Amps 1 31st December 2004 09:47 PM
Newbie Troubleshooting Sony CD Changer zozeppelin Digital Source 0 15th June 2004 01:03 AM
Troubleshooting dead amp...Help pedroskova Solid State 10 24th May 2003 10:15 AM


New To Site? Need Help?

All times are GMT. The time now is 05:36 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2