Duson PA75 repair - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th January 2012, 08:53 AM   #1
diyAudio Member
 
Join Date: Jan 2012
Default Duson PA75 repair

Hi,

I've been out of the audio hobby for a while and lately i decided to get my old gear back together. I still had my LS3/5A on the attic, so all i needed was a philips cd with 1541 Dacs, an Audioanalyse P90 and a set of Audioquest LS Cables.

This set played excellent, but i sold about everything 15 years ago, exept the LS3/5A's. I am gonna bypass the input board and and the volume / balance section of this amp.

Last week I found a used Duson PA75, and I payed 225,- Euro for it, not too bad. (i knew the Duson PA75 is practicly identical to the P90).

A few things i noticed when i hooked up the Duson. The sound was ok, but not what I expected. Too, the unit stayed ice cold. I opened the Duson to do some measurements.

Click the image to open in full size.

Uploaded with ImageShack.us

Last edited by Franck001; 14th January 2012 at 09:15 AM.
  Reply With Quote
Old 14th January 2012, 08:57 AM   #2
diyAudio Member
 
Join Date: Jan 2012
Click the image to open in full size.

Uploaded with ImageShack.us
  Reply With Quote
Old 14th January 2012, 09:10 AM   #3
diyAudio Member
 
Join Date: Jan 2012
A couple of things I noticed right away when opening the unit. Someone had been soldering in the unit before. There were some really bad solderjoints on some PCB's.

But anyway. I measured the current in both endstages, and it was 50 mA via T13, and 22mA via T14. I also noticed that there was 145mV on the speaker terminal on the richt channel. The offset was simple to correct with R14 pot, the Bias on the endstages was increased with R19 to 100mA per TIP (although i couldnt get the same bias on T13 and T14, probably because the were by far from matched)

Sadly i had to cough and accidently i sparked the PCD, so now t13 and 14 are gone, will pick up some new this afternoon.

Click the image to open in full size.

Uploaded with ImageShack.us

Click the image to open in full size.

Uploaded with ImageShack.us
  Reply With Quote
Old 22nd March 2012, 08:34 PM   #4
Bas is offline Bas
diyAudio Moderator Emeritus
 
Bas's Avatar
 
Join Date: Jan 2003
Location: Rotterdam Netherlands
Default PA100 Duson

Hi, Same problem here with Duson PA100. Have you got the thing working? Are the TIPs matched pairs?

B.
__________________
Less is more, KISS!
  Reply With Quote
Old 22nd March 2012, 09:00 PM   #5
diyAudio Member
 
tiefbassuebertr's Avatar
 
Join Date: Jul 2005
Location: D-55629 Schwarzerden
looks similar to this brand:
Audioanalyse PA-60 (PA60) Power Amp - where to get Schematic ??
audio analyse' - French made amp?

Last edited by tiefbassuebertr; 22nd March 2012 at 09:03 PM.
  Reply With Quote
Old 22nd March 2012, 09:06 PM   #6
Bas is offline Bas
diyAudio Moderator Emeritus
 
Bas's Avatar
 
Join Date: Jan 2003
Location: Rotterdam Netherlands
Duson was a Dutch company took over French Audio Analyse. Same design amp. but end transistors are matched pairs I think, keep blowing them out with bias adjusting.
Oscillating is a big problem with these amps.
__________________
Less is more, KISS!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is a repair possible? seebert Multi-Way 9 6th October 2011 05:27 PM
WANTED RCF L12P-24 or ATC PA75-314 steve hawkins Swap Meet 2 16th December 2009 10:53 AM
sub repair...need help ! artie in miami Subwoofers 1 10th April 2009 05:55 PM
Duson A10 - help needed diabolis Solid State 4 28th March 2008 07:40 AM
Fs Pa75-314 nissan_addict Swap Meet 0 16th January 2006 09:36 PM


New To Site? Need Help?

All times are GMT. The time now is 07:15 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2