NIKKO Alpha 230 with a fan on top - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st December 2011, 02:02 AM   #1
diyAudio Member
 
Join Date: Dec 2011
Default NIKKO Alpha 230 with a fan on top

Hi everybody!
I just got NIKKO ALpha 230 and it is working, but very hot. Al so, the level indicators are lit up to 8.5 wat level even at idling. If I push it with higher sygnal they go up to 120, 240 wats. For now I put a fan on top of it and it is running cooler. Should I try to fix the level indicators problem, or leave it and do you think the fan is helping? Please forgive my ignorance - new to this stuff!
Thanks!
Seasons Greetings!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help fixing Nikko Alpha 230 DiamondPilot Solid State 3 19th November 2010 04:32 PM
Nikko Alpha 230 amp salimchehab Solid State 1 19th November 2010 04:25 PM
Nikko Alpha 230 User and Service Manual wild-gazer Solid State 0 27th August 2009 06:09 PM
Another burnt Nikko Alpha 230 ecoda Solid State 1 28th November 2008 04:24 AM
Converting Nikko Alpha 230 to Leach Low TIM BrianDonegan Solid State 45 29th March 2005 10:40 PM


New To Site? Need Help?

All times are GMT. The time now is 04:40 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2