Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th September 2012, 12:49 PM   #111
Bensen is offline Bensen  Belgium
diyAudio Member
 
Bensen's Avatar
 
Join Date: May 2003
Location: Belgium, Limburg
Thanks for the tip Patrick!
Any idea where I could buy these?
  Reply With Quote
Old 30th September 2012, 01:10 PM   #112
diyAudio Member
 
meanman1964's Avatar
 
Join Date: Oct 2006
Location: Belgium the land of chocolate
Maybe in car shop?Will take a look myself.
  Reply With Quote
Old 14th October 2012, 08:51 PM   #113
Bensen is offline Bensen  Belgium
diyAudio Member
 
Bensen's Avatar
 
Join Date: May 2003
Location: Belgium, Limburg
Default Humming problem is solved!

I've put a 10R resistor between the audio ground (input and feedback) and power ground. With the input of the amp shorted, I can't hear a thing when keeping my ear against the tweeters.
  Reply With Quote
Old 14th October 2012, 09:04 PM   #114
Bensen is offline Bensen  Belgium
diyAudio Member
 
Bensen's Avatar
 
Join Date: May 2003
Location: Belgium, Limburg
Default new design

During solving all issues discussed above and searching for solutions, I designed in parallel a new amp.

- better VAS ==> more dominant 2nd ant 3th harmonic during FFT analysis
- MKP input capacitor instead of MKT
- 33R - 470F buffer between rails and LTP/VAS section
- BJT drivers instead of FET's ==> big improvement in sound! ==> much more depth in music
- better input bjt's (1775/872 instead of 3381/1349)

See the attachment of the current design states. I put in a jumper to select High Open Loop Bandwith.
Attached Images
File Type: jpg 20121014.JPG (213.9 KB, 162 views)
File Type: jpg 20121014_FFT_2.8Vpeak out.JPG (231.3 KB, 150 views)
File Type: jpg 20121014_output_THD.JPG (369.9 KB, 128 views)
  Reply With Quote
Old 14th October 2012, 09:31 PM   #115
Salas is online now Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Quote:
Originally Posted by Bensen View Post
I've asked one of the operators to change the thread title, sofar I haven't received an answer.
Changed it. Better use the report post triangle symbol, the one with the exclamation mark inside it for such requests also, so it goes in the reports queue that every mod sees, avoid PMs, they don't expect forum related requests there for sure.
  Reply With Quote
Old 7th November 2012, 12:35 PM   #116
Bensen is offline Bensen  Belgium
diyAudio Member
 
Bensen's Avatar
 
Join Date: May 2003
Location: Belgium, Limburg
Default Upgrade + listening impression

A lot happened the last weeks.
- first I've said that changing the drivers from FET to BJT's improved the sound (more depth in the music)
- but after more listening, I liked the FET's as drivers more ==> a lot more detail/contrast in the music

==> disconnecting the middle point of the driver outputs with the ouput of the amp changed a lot.

I still have the PMA700V amp to compare with. At this point I for sure like my amp more than the PMA700V, my amp has more details in the hight's and better base response.

Have a look at the attachement, this is where I'm working towards. At this point the VAS degeneration is stil 560Ohm and LTP source resistors are 2K2. All the rest is identical.
Attached Files
File Type: pdf 1775_872IPS 1530_201OPS.pdf (439.0 KB, 53 views)
  Reply With Quote
Old 7th November 2012, 01:38 PM   #117
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
open loop bandwidth seems unusually low @ ~+50dB
Are you measuring that correctly?
__________________
regards Andrew T.
  Reply With Quote
Old 7th November 2012, 01:49 PM   #118
Bensen is offline Bensen  Belgium
diyAudio Member
 
Bensen's Avatar
 
Join Date: May 2003
Location: Belgium, Limburg
I checked it again, and yes, according to my knowledge teh 50dB is correct.
I use -V(a)/V(b) as parameter for AC-analysis.

It was actually one of my intentions to use a rather low open loop gain, as mentioned many times by NP, to much gain kills the live in the sound.
  Reply With Quote
Old 3rd December 2012, 02:03 PM   #119
Bensen is offline Bensen  Belgium
diyAudio Member
 
Bensen's Avatar
 
Join Date: May 2003
Location: Belgium, Limburg
Default Stability tests on final version

I made a proto PCB from the final circuit below, in order to make some decent stabiltity tests.

personaly, I think this version sounds terrific. But besides sounding good, it has to be stable. I don't have much experience yet in square wave testing. Therefore I've attached pictures of the scope readings. The filename of the picture is: peak-peak voltage / Freq / 8R / C-load. The last two pictures are done wihth 4Vpp instead of10. If I increased the ouput voltage higher then 4Vpp with this load, there was massive ringing on the square wave.

Can anyone tell me whether i'ts good enough for home use?

Greetz
Attached Images
File Type: jpg Circuit.JPG (171.4 KB, 75 views)
File Type: jpg 1- 10Vpp 20K 8R -comp.JPG (140.4 KB, 69 views)
File Type: jpg 4- 10Vpp 20K 8R 33n -comp.JPG (129.4 KB, 25 views)
File Type: jpg 7- 4Vpp 10K 8R 100n -comp.JPG (129.6 KB, 28 views)
File Type: jpg 8- 4Vpp 1K 8R 1 -comp.JPG (129.8 KB, 35 views)
  Reply With Quote
Old 4th December 2012, 02:04 PM   #120
Bensen is offline Bensen  Belgium
diyAudio Member
 
Bensen's Avatar
 
Join Date: May 2003
Location: Belgium, Limburg
Bump
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Subwoofer Amp Design Suggestions SpikedCola Chip Amps 45 28th February 2011 01:31 AM
Offline SMPS duty cycle, core & bridge JohnT_diy Power Supplies 10 16th May 2008 10:22 PM
Advice on a 15"+ sealed subwoofer design gwgjr31 Subwoofers 25 27th April 2006 04:18 PM
I need help with my 30" subwoofer design jhung1983 Subwoofers 11 13th December 2005 12:48 AM
Just a little note : When you wideband amp oscillates at 200KHz and you dont know why sonnya Solid State 6 1st August 2003 06:08 PM


New To Site? Need Help?

All times are GMT. The time now is 03:20 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2