Crown XLS 602 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th October 2011, 04:45 PM   #1
diyAudio Member
 
Join Date: Oct 2011
Location: Village Beautiful Florida
Default Crown XLS 602

Hi guys, I am very glad I found this site and maybe some help.
This is my first post .

I have this Crown XLS 602 which has given me the same problem two times.

The first time, I took it to a Crown registered dealer and fixed exactly a year ago. There is not too much that she is doing but playing my music at home running a mini studio, two hours tops.

This time, the same cracking noise. I am asked to shell close to 400 dollars to the same dealer for the same problem and this is so not happening.

They estimated that it will take 8 transistors each in/out, but that was done last year.
This is my dilemma, I have the skills to trouble shoot a laptop mother board and fix my own car, and have used a oscilloscope in a lab setting and this amp has been unplugged for days just in case.
I am sure there must be a write up of the procedure to replace the 16 transistor on this site. Any help either way will surely be appreciated.

Thanks!

A picture is worth...

Click the image to open in full size.
  Reply With Quote
Old 8th October 2011, 02:00 PM   #2
diyAudio Member
 
Join Date: Oct 2011
Location: Village Beautiful Florida
It has been a day and I have had at least 20 visitors and no response. As can be seen at the bottom, there is a screw missing from this new amp as it left the tech shop registered by Crown. The first time it went it was in excellent condition, actually brand new, the last time fair.The more it goes there, the more scratches it received, the more reason I need to fix this myself with or without help. Thanks!
  Reply With Quote
Old 8th October 2011, 02:10 PM   #3
diyAudio Member
 
jackand08's Avatar
 
Join Date: Oct 2008
Location: England
For a starter, does the cracking noise occur when there is no signal, when the level settings are altered, when music is played (normal volume) or when it is played loudly? Including some more information like this will help others to help you.

As well as that, I'd advise to check the board closely for any capacitors that appear to be bulging/leaking, any burnt/heat scorched components or areas of the board and if you really want to, check the solder side of the board for any dry joints. When doing this, please bear in mind that those capacitors at the bottom may still hold a charge which could give you (at most) a bit of a shock if you happened to come into contact with them.
__________________
Jack
"Near enough is good enough, so good enough is best"
  Reply With Quote
Old 8th October 2011, 02:25 PM   #4
diyAudio Member
 
east electronics's Avatar
 
Join Date: Jan 2006
Location: Athens GREECE
the above advice is correct ....you probably have a car with a flat tire and you are looking for an engine replacement ...that is bad practice

output transistors at least under the way you describe things cannot be responsible for such a problem ... output transistors either work or simply are shorted resulting blown fuses protection circuits activated and so on .

Be advised now this is a forum from very happy friendly and helpful people .... that means that from the 20 people that read your post most of them understood that either you are a nb or an amateur which is absolutely no problem cause each and everyone of us has already been there but the problem is that ...

even if someone is willing to help you there is a serious "language " problem and things said are probably not easy for you to understand .

Finally you need to use the advise given so far and we will hear from you again i think ....

cracling sound might occur from
--- bad soldering ....
--- faulty output relay
--- and a dirty pot

--- check the soldering
--- tick the relay with a screw driver while operating ...if crackles come up you got it !!!
--- spray the pots with some contact cleaner or de-oxidizer


kind regards sakis
__________________
SERVICE ΕΝΙΣΧΥΤΩΝ ΚΑΙ ΙΑΠΩΝΙΚΩΝ ΜΗΧΑΝΗΜΑΤΩΝ ΗΧΟΥ www.eastelectronics.gr
  Reply With Quote
Old 8th October 2011, 04:36 PM   #5
diyAudio Member
 
indianajo's Avatar
 
Join Date: Jan 2010
Location: Jeffersonville, Indiana USA
I only check diy once a day. SS amps is mostly design, which I don't do, repair shows up more in PA amps (which this is) under live sound. You can check for bad solder joints if you can operate it with the case off, by poking at the components with a plastic stick and listening. A dead ball point pen (stick) comes to mine- no metal. You can also spray circuit cooler on things but that is more expensive. You can also just look for "dry" solder joints, or crystalized looking ones. Reheating usually works, but sometimes you have to add a little solder. I use rosin core lead-tin solder, 22 to 28 gauge. I use a Weller WP25 iron with a 7/32" screwdriver tip (extra). Don't use conductive tools with the power on, and take all jewelry off while working around it, you don't want a bad burn from your ring or anything.
__________________
Dynakit ST70, ST120, PAS2,Hammond H182(2 ea),H112,A100,10-82TC,Peavey CS800S,1.3K, SP2-XT's, T-300 HF Proj's, Steinway console, Herald RA88a mixer, Wurlitzer 4500, 4300
  Reply With Quote
Old 8th October 2011, 07:56 PM   #6
diyAudio Member
 
Join Date: Oct 2011
Location: Village Beautiful Florida
Quote:
Originally Posted by jackand08 View Post
For a starter, does the cracking noise occur when there is no signal, when the level settings are altered, when music is played (normal volume) or when it is played loudly? Including some more information like this will help others to help you.

As well as that, I'd advise to check the board closely for any capacitors that appear to be bulging/leaking, any burnt/heat scorched components or areas of the board and if you really want to, check the solder side of the board for any dry joints. When doing this, please bear in mind that those capacitors at the bottom may still hold a charge which could give you (at most) a bit of a shock if you happened to come into contact with them.
Thanks for responding! The crackling noise starts at boot up (buzz sound) and as the music plays, it reacts as if it is a blown speaker regardless of volume unable to come to grip with the request. I have gotten a 407.03 dollar estimate from the Crown registered dealer and they have already replaced the same 16 transistors after diagnosis, unless they are lying to the customer.

Last edited by MaitreG; 8th October 2011 at 08:19 PM.
  Reply With Quote
Old 8th October 2011, 08:07 PM   #7
diyAudio Member
 
Join Date: Oct 2011
Location: Village Beautiful Florida
Quote:
Originally Posted by sakis View Post
the above advice is correct ....you probably have a car with a flat tire and you are looking for an engine replacement ...that is bad practice

output transistors at least under the way you describe things cannot be responsible for such a problem ... output transistors either work or simply are shorted resulting blown fuses protection circuits activated and so on .

Be advised now this is a forum from very happy friendly and helpful people .... that means that from the 20 people that read your post most of them understood that either you are a nb or an amateur which is absolutely no problem cause each and everyone of us has already been there but the problem is that ...

even if someone is willing to help you there is a serious "language " problem and things said are probably not easy for you to understand .

Finally you need to use the advise given so far and we will hear from you again i think ....

cracling sound might occur from
--- bad soldering ....
--- faulty output relay
--- and a dirty pot

--- check the soldering
--- tick the relay with a screw driver while operating ...if crackles come up you got it !!!
--- spray the pots with some contact cleaner or de-oxidizer


kind regards sakis
Thanks for the response Sakis!

I may be a nb at this site but belong to many other forums for my exotic car and other hobbies. You may be confusing being anxious to find some help, weary of avoidance of liability and hence not getting a quick response with language problems. Nothing to fear from here. :

The Crown authorized dealer has already charged me 80 dollars for the diagnosis, did not put all the washers back in and missing a screw not counting the many scratches that they alone created. This is a new amp that was serviced the first time last year by the same dealer for the same reason. Everything looks clean. Please don't put me in a shoe I can not wear. Cheers!
Again, thanks for responding.

Last edited by MaitreG; 8th October 2011 at 08:22 PM.
  Reply With Quote
Old 8th October 2011, 08:13 PM   #8
diyAudio Member
 
Join Date: Oct 2011
Location: Village Beautiful Florida
Quote:
Originally Posted by indianajo View Post
I only check diy once a day. SS amps is mostly design, which I don't do, repair shows up more in PA amps (which this is) under live sound. You can check for bad solder joints if you can operate it with the case off, by poking at the components with a plastic stick and listening. A dead ball point pen (stick) comes to mine- no metal. You can also spray circuit cooler on things but that is more expensive. You can also just look for "dry" solder joints, or crystalized looking ones. Reheating usually works, but sometimes you have to add a little solder. I use rosin core lead-tin solder, 22 to 28 gauge. I use a Weller WP25 iron with a 7/32" screwdriver tip (extra). Don't use conductive tools with the power on, and take all jewelry off while working around it, you don't want a bad burn from your ring or anything.
Thanks Indianajo! Advice well taken. It looks like the system needs to be contained in its complete environment before it is turned on as per specs, so I will not chanced powering it on any other way. By the way, the only foreign (un-computerized) soldering that was done was by the authorized dealer.
This is the step I am in right now;! Please do not try this at home.

Click the image to open in full size.

Last edited by MaitreG; 8th October 2011 at 08:24 PM.
  Reply With Quote
Old 8th October 2011, 08:20 PM   #9
diyAudio Member
 
Frank Berry's Avatar
 
Join Date: Sep 2003
Location: Midland, Michigan
You can replace the amplifier for less than the cost of repair.
__________________
Frank
  Reply With Quote
Old 8th October 2011, 08:22 PM   #10
diyAudio Moderator
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Chatham, England
Yup. Get a Yamaha P7000 or similar. They just work.
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crown XLS 602 Bridge switch mod wild-gazer Solid State 3 18th July 2012 09:43 PM
Crown 602 XLS Power Issue msquicc Solid State 10 14th June 2011 11:51 AM
Crown XLS 602 service manual stevep314 Solid State 4 25th April 2010 11:02 PM
crown xls 602 galush Parts 1 4th June 2009 02:40 PM
crown xls 602 amp galush Solid State 0 6th April 2009 05:41 PM


New To Site? Need Help?

All times are GMT. The time now is 06:24 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2