Nikko Beta 20 preamp - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th February 2013, 04:52 PM   #11
adason is offline adason  United States
diyAudio Member
 
adason's Avatar
 
Join Date: Nov 2004
Location: Maryland
Hi sakis, thanks for fast response. I checked +/- 12 volts suply, it works fine, if it would not, servo in next stage would not work. So I measure correct +/- 12 volts comming to pre-pre, and most of the voltages indicated in the schematics are close to the spot.
I replaced already two input capacitors in each half, and two output caps. Should I go ahead and replace all of the caps in pre-pre section? I need something more specific to go after.
  Reply With Quote
Old 8th February 2013, 04:54 PM   #12
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Are both channels equally affected... I'm guessing so.

Strange problem. Obviously check supplies as sakis mentions. Beyond that, and I think I'd be looking closely for some quirk in its operation first off. Switch positions/jumpers etc.

Might help to see a bit more of the circuit and the switch operation. As shown it should have masses of gain. Worth checking physical continuity across the switch and confirming that the 1K and 10 ohm really are in contact.

That servo looks scary with a 741 and large (diy) bipolar caps.
__________________
-------------------------------------------------------
A simulation free zone. Design it, build it, test it.
  Reply With Quote
Old 8th February 2013, 04:56 PM   #13
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Are the DC conditions OK in the front end ? Midpoint around zero volts DC ?
__________________
-------------------------------------------------------
A simulation free zone. Design it, build it, test it.
  Reply With Quote
Old 8th February 2013, 05:20 PM   #14
adason is offline adason  United States
diyAudio Member
 
adason's Avatar
 
Join Date: Nov 2004
Location: Maryland
Thanks Mooly for suggestions. As I am at work now, I can not verify any of those, but, but, you are absolutely right, it should have sooo much gain. It occured to me before that simple switch mabe be?
  Reply With Quote
Old 8th February 2013, 05:22 PM   #15
diyAudio Member
 
east electronics's Avatar
 
Join Date: Jan 2006
Location: Athens GREECE
one other thing that might be a problem is the switch there might be trouble also other than that scope will tell easily
__________________
SERVICE ΕΝΙΣΧΥΤΩΝ ΚΑΙ ΙΑΠΩΝΙΚΩΝ ΜΗΧΑΝΗΜΑΤΩΝ ΗΧΟΥ www.eastelectronics.gr
  Reply With Quote
Old 9th February 2013, 11:54 AM   #16
adason is offline adason  United States
diyAudio Member
 
adason's Avatar
 
Join Date: Nov 2004
Location: Maryland
Hi gents, here is an update. There are good news and there are bad news. The good news is that pre-pre section is working, the bad news is that phono selector is totaly busted. Well, from the front it behaves fine, you can select four positions, it has nice feel to it, it clicks. However, from that mechanism on the front pannel, which includes two plastic wheels with teeth, there is long flat cable which has flat metal advancing in and out, you know what I mean, an that part is not moving. So its only in one position, no matter what is selected on the front pannel. So the mystery is solved.
Unfortunately, there is no way I can fix that, since even the actual selector on the board is busted, it has some broken plastic parts inside. There is no way I can replace it, first I have no parts to replace it with, second it has dozens of pins soldered on the pcb. All I can do this time is to fix it in one position by wires.
In any case, thanks for the help.
  Reply With Quote
Old 9th February 2013, 02:10 PM   #17
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
That's a shame. I know those switch things... they were pretty common in the 80's and 90's in a lot of gear.

No easy answer to that one.
__________________
-------------------------------------------------------
A simulation free zone. Design it, build it, test it.
  Reply With Quote
Old 9th February 2013, 02:56 PM   #18
diyAudio Member
 
boywonder's Avatar
 
Join Date: Jan 2008
Location: So.Cal.
adason: I have an organ donor Yamaha preamp with a similar setup. If these are the parts you are looking for, let me know and I can unsolder and send them to you.
Attached Images
File Type: jpg yamaha pre 2.JPG (624.1 KB, 68 views)
File Type: jpg yamaha pre.JPG (696.9 KB, 60 views)
  Reply With Quote
Old 10th February 2013, 01:11 AM   #19
adason is offline adason  United States
diyAudio Member
 
adason's Avatar
 
Join Date: Nov 2004
Location: Maryland
yes, yes, those are the switches...boywonder, thanks for the offer, but please do not do it, thats way too much work and I am affraid it would not lead to success
those switches in nikko are most likely configured differently, it would be hard to match the contacts, the preamp phono switch has four positions in three sections (the schematics I provided is only part of it...; mc, phono 1 47k, phono 1 100k, phono 2...that is 12 pins per side, 24 pins on the pcb to unsolder, I do not want to do that...

I am going to make simple selector mc / mm...it will take just one switch on the back

this preamp is never be for anybody else but for me, so it can be ugly and moded, so the switch on the back is no problem, swith on the front will be non-functional

I plan to use this for experimentations, since I do have better preamps...
  Reply With Quote
Old 10th February 2013, 01:13 AM   #20
adason is offline adason  United States
diyAudio Member
 
adason's Avatar
 
Join Date: Nov 2004
Location: Maryland
thanks everyone for help, I am glad that pre-pre is fully fuctional, so I will finish re-caping I started...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Beta 12LTA + Beta 12A-2: is this open baffle concept viable? chazdrumzalot Full Range 25 31st December 2011 08:28 AM
wanted: Coral Beta 8 or Beta 10 full range speaker francofil Swap Meet 2 28th April 2010 08:34 AM
Nikko Beta Ii east electronics Solid State 7 19th March 2010 06:45 AM
Nikko pre-amplifier Beta II schematics for driving my F4 lykkedk Solid State 9 8th November 2009 08:10 AM
Some questions on new preamp XP-20 strange Pass Labs 2 2nd October 2008 09:19 PM


New To Site? Need Help?

All times are GMT. The time now is 11:20 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2