Pioneer SA7300 amp - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st September 2011, 04:21 PM   #1
diyAudio Member
 
Join Date: Jun 2011
Default Pioneer SA7300 amp

Hi, I was wondering if anyone would be able to help with the repair of my old Pioneer SA7300 amp?

I was using it and all of a sudden there was no sound, I noticed that the protection circuit was not allowing the system to run. I downloaded a service manual and got as far as the power supply which checks out voltage wise ok. it is the model with a hybrid in the O/p stage but I dont think these power amps are faulty. I have been checking out the transistors and diodes in the main amp stage but seem to be having trouble with identifying the components from the Schematic. Does anyone have a layout of the components.

Is there anyone who could advise of any test procedures which I might be able to use to establish which side is faulty, I remember changing one of the hybrids in the mid 80s and at the same time paid for the service manual from Pioneer in Slough but in time it has got mislaid. Now the protection relay will not switch and the system just lays in the pre state.

I have tried the system without load and it is the same, I am thinking of removing one hybrid at a time to see weather i can get it to switch and apart from checking every component is there anyone who can advise me.

Thanks, Peter
  Reply With Quote
Old 21st September 2011, 07:14 PM   #2
diyAudio Member
 
Nico Ras's Avatar
 
Join Date: Nov 2005
Location: East Coast of South Africa
Try sending Sakis a PM, he is probably the most experienced repair man on the forum.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pioneer M25 power amp bias & offset adjust ? Bernhard Solid State 21 6th June 2010 05:47 PM
12"Pioneer 400W subwoofer with a RF Punch 360.2 amp? bigwig Car Audio 1 11th January 2005 05:42 PM


New To Site? Need Help?

All times are GMT. The time now is 11:41 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2