PL 700 Series II went psycho! - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th September 2011, 05:18 PM   #1
diyAudio Member
 
Join Date: Sep 2011
Default PL 700 Series II went psycho!

New to this forum. Hope someone can give me some insight. FIY, I am no electronics expert. Here's what happened...

Amp was plugged into power and powered on, gains were turned all the way down. I was not actually using it when the incident occurred. All of a sudden about a billion decibels was blowing out of the speakers (Bose 901s). Luckily I was nearby to pull the power. Disconnected the amp, opened it up but saw nothing obviously wrong and really didn't expect to.

Any ideas on what happened and what it might take to repair it?

Thanks for your time,
digitalanvil
  Reply With Quote
Old 16th September 2011, 09:57 PM   #2
diyAudio Member
 
Join Date: Sep 2011
No takers? Not even a guess on what might have happened?
  Reply With Quote
Old 17th September 2011, 03:23 AM   #3
diyAudio Member
 
Join Date: Nov 2008
Must be the speakers. I never liked Bose (and they do not do 10^9 dB). And what is a PL 700 anyway? E
  Reply With Quote
Old 17th September 2011, 03:26 AM   #4
Tajzmaj is offline Tajzmaj  Slovenia
diyAudio Member
 
Join Date: Mar 2011
Location: Ljubljana
Such thing can be caused by missing ground at the volume pots.....if we are talking about Phase Linear 700.......be careful such amp can burn something.....I have 700b version....
Regards, Taj
  Reply With Quote
Old 17th September 2011, 03:29 AM   #5
Tajzmaj is offline Tajzmaj  Slovenia
diyAudio Member
 
Join Date: Mar 2011
Location: Ljubljana
Ah one more thing. It can be also caused by some bad input cable...maybe some minijack to rca......which can also interrupt the ground.....
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Phase Linear 700 series II restoration P.L.F. Solid State 51 27th January 2013 03:32 PM
BEYER 700 series capsule (i need) tgregorek Swap Meet 0 22nd July 2009 11:30 PM
Phase Linear 700 Series II - 60Hz Hum craigstrat Solid State 6 28th September 2008 02:45 AM
Opinions on Vifa Pl and CDT ES series gixxierific Car Audio 0 12th May 2007 01:01 PM
vifa PL series ucla88 Multi-Way 1 22nd December 2001 09:30 PM


New To Site? Need Help?

All times are GMT. The time now is 11:06 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2