parasound hca 800ii - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th September 2011, 02:28 AM   #1
samnor is offline samnor  United States
diyAudio Member
 
Join Date: Sep 2011
Question parasound hca 800ii

Hi, new to this forum. I just picked up a parasound hca 800ii amp on ebay. Anyone who owned this amp care to chime in on its performance and any issues you ran into. On a related note, I also have a parasound hca 1500a which was running hot on one side and is in a repair shop currently. They seem to be dragging their feet on this as they claim its an old amp.. Has anyone run into this kind of warming up problem and possible fixes. Thanks in advance.
Sam
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
parasound HCA-1206 (Tony at Parasound.com) ostie01 Solid State 1 10th July 2012 05:24 AM
parasound hca-1000a infiniti52 Parts 2 11th December 2010 12:21 AM
Parasound HCa 1000a infiniti52 Solid State 10 25th September 2010 12:26 PM
Parasound HCA-2205AT dkahs Solid State 12 19th September 2008 12:36 PM
Parasound HCA-1200 Leon1 Solid State 0 16th January 2008 06:02 PM


New To Site? Need Help?

All times are GMT. The time now is 02:16 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2