Rotel RA-870 intermittent channel (simple fix?) - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st August 2011, 11:29 PM   #1
diyAudio Member
 
Join Date: Aug 2011
Default Rotel RA-870 intermittent channel (simple fix?)

First post here, and so predictably newbish. I got this Rotel integrated amplifier real cheep as a second unit and worked perfectly for years alongside my Creek. I've never really maintained it, but all the pots and switches have always been smooth and clean-sounding ... But recently the left channel has been cutting out.

Often after I play from a steady source for a long time (tuner, say) and don't touch anything the channel will come back and sound great, but then if you so much as breathe on the deck it disappears again (fiddling with any switches: stereo/mono, input, mm/mc pretty much guarantees the channel to drop -- it also happens from vibrations and whatnot; the volume control has nothing to do with it, though. The headphone jack is unswitched).

I can post pics of the inside if that would help. I don't know much about stereo electronics specifically but I know electrical parts OK—can solder and all that (though have neither iron nor multimeter right now)—and as far as I can tell the only dodgy connections visible from the top of the board are for LED diodes, all of which work fine.

Any theories where I should look for or what I should start by cleaning?

Thanks, guys.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rotel RA-311 left channel noise mogga Solid State 3 26th February 2011 09:17 AM
Rotel RA-930AX One channel out No sound mrfix90 Solid State 6 2nd September 2009 06:58 AM
Simple SE - one channel intermittent problem astrodog Tubes / Valves 15 25th May 2009 04:27 PM
Simple upgrade for Rotel RA-01 amp.. ashok Solid State 1 14th December 2004 01:09 PM
One channel louder... Rotel RA-971 rsdent Solid State 3 22nd April 2004 05:09 AM


New To Site? Need Help?

All times are GMT. The time now is 06:06 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2