Electrocompaniet AW 180M adjustments - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th June 2011, 09:42 AM   #1
Elan67 is offline Elan67  Italy
diyAudio Member
 
Join Date: Sep 2007
Default Electrocompaniet AW 180M adjustments

Hi all,
I almost fixed a (...completely...) broken EC AW 180M.
Adjusting dc offset & bias was quite trivial.
R44 for bias current (9-8.5mV across 0.2 ohm restistor = 45-42.5mA as the working one)
and R7A to null dc offset before ouput relay.

Now there is a third trimpot (R6P) on the so called "Sister Board" near IC protector.
EC firmly but kindly but refused to give me any help or hint .
Amplifiers measures and sounds good but ...
Is there someone who can give me any help?

Thanks in advance
  Reply With Quote
Old 5th September 2011, 01:55 PM   #2
diyAudio Member
 
Join Date: Nov 2004
Location: Athens
Possibly an adjustment for the output overcurrent protection.
__________________
'in acts and works
bigger than a great wale's tail'
  Reply With Quote
Old 30th September 2012, 02:23 PM   #3
diyAudio Member
 
Join Date: Oct 2009
Welcome
Very nice project!!
I would like to ask for help
Electrocompaniet AW-180 schematics I need
Thanks for your help
my email address
gargafater@freemail.hu
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Did someone clone an Electrocompaniet AW amplifier? vzs Solid State 35 12th October 2009 05:19 AM
Electrocompaniet AW-100DM ManUtd Solid State 17 31st October 2008 11:43 PM
Electrocompaniet AW-250r problem. help please maxzimum Solid State 13 2nd May 2008 11:38 AM
Electrocompaniet AW 250 AMP. hogue Solid State 1 1st March 2004 05:48 AM
Electrocompaniet AW-100DM ManUtd Solid State 0 24th September 2003 08:27 AM


New To Site? Need Help?

All times are GMT. The time now is 04:39 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2