HELP - SONY XO-3 No Tuner output - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th May 2011, 11:45 PM   #1
budkor is offline budkor  United Kingdom
diyAudio Member
 
Join Date: Sep 2008
Default HELP - SONY XO-3 No Tuner output

Hi All

Got this SONY XO-3 Receiver a few days ago. It is very unque in that it has AMP, Tape Deck and 3 Band tuner (FM MW LW). I have not seen or read about it before.

But when I connected it up - the amp sounds fantastic from my SONY CDP and SONY turntable, the Tape Deck works fine too, but the Tuner - FM is barely audible with very good FM antenna - that's with volume full up, MW & LW has no output at all (MW & LW has built in ferrite antenna at the back - this should work fine, but no sound).

Tonight, I open it up just to see if there is any short or disconnected wires - but nothing I can find. Everything seems together. I have connected long wire into the MW antenna terminal as well - not a sausage. Internal components all seem clean and intact (not messed with, it seems).
Where next should I look into?


Thanks in advance.
  Reply With Quote
Old 12th May 2011, 10:13 AM   #2
diyAudio Member
 
EchoWars's Avatar
 
Join Date: Dec 2002
Location: Left of the Dial
Time to check the power supply voltages to the tuner section. See if you can locate a service manual. http://www.stereomanuals.com
  Reply With Quote
Old 12th May 2011, 11:49 AM   #3
budkor is offline budkor  United Kingdom
diyAudio Member
 
Join Date: Sep 2008
Thanks echowars.

Weird thing is that I can hear some stations on FM, but very quiet - must put the volume up to about 12 oclock position, but nothing on MW and LW.

I will try to find the service manual, but this model seems a bit obscure one - which might be difficult to find it. cheers.



Quote:
Originally Posted by EchoWars View Post
Time to check the power supply voltages to the tuner section. See if you can locate a service manual. High Quality Service Manuals Schematics Repair User Owner Operating Instructions Vintage Classic Audio Stereo PDF FREE
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for SONY ST-80F tuner manual djoffe Solid State 0 24th July 2010 09:12 PM
Someone has offered me a Sony ST 5130 tuner, should I take it ?? Shoog Analogue Source 6 30th June 2010 09:10 PM
Sony ST-S310 tuner trouble hiwiho Analogue Source 5 5th November 2006 10:49 AM
Bad Tuner on Sony REC-800 snaps98 Car Audio 0 5th October 2005 08:58 PM
Problem with Sony tuner memory Lourens Analogue Source 8 18th July 2005 06:45 PM


New To Site? Need Help?

All times are GMT. The time now is 04:40 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2