Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

KA-3020SE
KA-3020SE
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th April 2011, 04:22 PM   #1
HiFiKA3020SE is offline HiFiKA3020SE
diyAudio Member
 
Join Date: Apr 2011
Default KA-3020SE

Dear Forum members,

I'm new here, hope you can help and this is the correct place to post

I've recently purchased a KA-3020SE amp made by Kenwood. I have a few problems with it.

1) Should be easy to solve - The Vol pot is noisy, so am going to use contact cleaner.

2) The bigger problem - The left channel is great. The right channel is always much lower volume and sometimes crackles. Also when the volume is zero I get some music through the right speaker still (nothing through left - as it should be). So the fault seems to be with the right channel.

Are the two faults linked? e.g. is it just the vol pot needs cleaning or is there something that needs replacing like capacitors?

I have a pdf of the schematics but it seems to miss off the parts list and some of the circuit diagrams. The person that scanned didn't do a very good job! does anyone have a better copy?

Thanks for your help. I'm new to this HiFi DIY as you can probably tell!!
  Reply With Quote
Old 20th April 2011, 05:04 PM   #2
5th element is offline 5th element  United Kingdom
diyAudio Member
 
5th element's Avatar
 
Join Date: Oct 2002
Location: England
This simply sounds like bad contacts, either in the pot, a dry solder joint or a dry coupling electrolytic.
__________________
What the hell are you screamin' for? Every five minutes there's a bomb or somethin'! I'm leavin! bzzzz! Now with website! www.5een.co.uk under construction.
  Reply With Quote

Reply


KA-3020SEHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie - Kenwood 3020SE mains noise? jimh0612 Solid State 24 13th November 2012 09:33 AM
Kenwood Ka-770b dexter2003 Solid State 7 3rd July 2008 05:22 PM
Kenwood 3020SE Fidelity Audio Solid State 1 30th April 2008 09:47 AM
Kenwood KA-5040R Briek Solid State 2 4th March 2007 08:54 AM
Kenwood KA-88 gurusan Solid State 7 17th August 2004 11:18 AM


New To Site? Need Help?

All times are GMT. The time now is 09:05 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki