NAD 214 125V 7 ampFuses needed - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th April 2011, 05:00 PM   #1
diyAudio Member
 
Join Date: Mar 2011
Default NAD 214 125V 7 ampFuses needed

I need help identifying fuse & finding a source for NAD 214 125V 7 amp fuse. Slow/fast/electronic? No one locally has this fuse. thanks!
  Reply With Quote
Old 8th April 2011, 05:38 PM   #2
jaycee is offline jaycee  United Kingdom
diyAudio Member
 
Join Date: Apr 2004
Location: Norwich, UK
A 250V 6.3A time-delay/anti surge fuse will work. However, if the fuse has blown, it is highly likely the unit is faulty. Fit one replacement fuse, if this blows then there is a fault.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NAD 214 schematics EspenE Solid State 53 2nd February 2012 09:43 PM
Modifying the NAD 214 altair Solid State 5 8th April 2011 05:25 PM


New To Site? Need Help?

All times are GMT. The time now is 03:03 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2