diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Solid State (http://www.diyaudio.com/forums/solid-state/)
-   -   EV p 2000.... (http://www.diyaudio.com/forums/solid-state/186266-ev-p-2000-a.html)

amptech 2nd April 2011 10:33 AM

EV p 2000....
 
Here's a real beast of an amp the p2000 ...this chap say's we blow our bass bin's with this beast:mad:

our young sound guy from the college was in charge has he's done gig's before.. All the level's on the main mixer was turned up full on the desk even the clipping leds flashing like mad:mad:...

MMM not a good idea to mess with this beast...still on powering her up it went straight in the limit mode led display?

I did get more information of how it was connected up..3 sub's on one channel and two mid top boxes connected on channel two...:eek:

still on wards time to get stuck in and see what's been cooked..:D

amptech 2nd April 2011 10:34 AM

It's the EV P2000...

amptech 15th April 2011 11:09 PM

This one had plenty of burnt parts and short circuited power transistors...

After 4 hours of checking the faulty channel (B) A channel was ok.. that done it was time to power it up...power on.. full led's fans..then more bias and power supply corrections to be done then 4 hour soak test at full power with 3kw dummy loads...what a beast of an amp!


All times are GMT. The time now is 09:10 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2