Pioneer SA 7300 power dropping out - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd April 2011, 03:37 PM   #11
amptech is offline amptech  Scotland
diyAudio Member
 
Join Date: Jan 2009
Location: Glasgow
Send a message via MSN to amptech
I rememberer these old silver amps now,,,built to last and stand up to rough use,well to a point..it's going to be hard getting circuit info for this old timer... Does your one have the blue led front panel display unit to the left hand side?
  Reply With Quote
Old 3rd April 2011, 05:12 PM   #12
amptech is offline amptech  Scotland
diyAudio Member
 
Join Date: Jan 2009
Location: Glasgow
Send a message via MSN to amptech
Have you retried powering up the pioneer with out speaker loads connected?

Before the relay cut's in/out how does the music to your speakers sound? weak...distorted.
Top speed things up we need to know how things sound/
  Reply With Quote
Old 3rd April 2011, 05:27 PM   #13
amptech is offline amptech  Scotland
diyAudio Member
 
Join Date: Jan 2009
Location: Glasgow
Send a message via MSN to amptech
Is your silver pioneer have it's blue led display to the left side or in the middle?

you say it drop's 'out' at any level...is there any distortion or is the music level coming out the speaker side weak?..

we need to know how things sound to speed the repair up, retry powering up with out speaker loads connected..
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Has anyone heard of the Pioneer SA-7300 amplifier made back in the 70's? pkgum Solid State 17 14th November 2013 02:24 PM
My whole amp mod and rebuild log Pioneer SA-7300 with 26 pics! rg12 Solid State 18 27th April 2012 10:35 AM
Which caps to replace in Pioneer SA-7300 rg12 Construction Tips 12 12th August 2010 05:32 PM
Pioneer SA-9800 Power Supply RaidersGuy Solid State 0 20th October 2005 06:52 AM


New To Site? Need Help?

All times are GMT. The time now is 09:08 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2