Threshold T800 and T400 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th March 2011, 01:09 PM   #1
diyAudio Member
 
Join Date: Mar 2011
Default Threshold T800 and T400

I own one of each but I am hunting for service manuals or at least diagrams.

The T800D plays great but both meters stopped working at the same time so I suspect a common ground problem.

The real patient is the T400 . I suspect the IGBTs are gone in one channel : (

So I am hunting for a diagram and a source for the IGBTs. Does that come across naive? : )

regards, Bo
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford Fosgate T400-4 mike49504 Car Audio 7 13th November 2010 11:23 PM
Rockford Fostgate T400-2 dead mbates14 Car Audio 5 13th July 2010 06:15 PM
Kenwood P-T400 - line level output ? jives11 Analogue Source 1 2nd October 2008 03:50 PM
Threshold T2 T3 T400 Service manuals emilg1955 Vendor's Bazaar 0 26th June 2007 11:35 PM


New To Site? Need Help?

All times are GMT. The time now is 02:38 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2