Help debugging a Sonus Faber Musica - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th March 2011, 07:33 PM   #1
diyAudio Member
 
Join Date: Dec 2005
Location: israel
Send a message via MSN to ronenash
Default Help debugging a Sonus Faber Musica

Hi all,

I need some help debugging a Sonus Faber Musica amplifier. I have the service manual (attached). I followed the instructions for setting DC offset and all worked fine. When I tried to set the quiescent voltage per the instruction on page 4, the left channel was not a problem and with the right channel no matter how much I turn the pot the voltage measired stays at 0mv.
The amplifier works and both channels play music although the right side of the heatsink where the output mosfets for the right channel are localted does not heat up as much under normal operation. I assume this is due to low bias current on that channel.

Can anyone assist in what could be the problem?

Service manual Musica (1).pdf - Windows Live

Thanks
ronenash.
__________________
ronenash
  Reply With Quote
Old 29th June 2011, 12:25 PM   #2
diyAudio Member
 
Join Date: May 2011
hi did you get your problem sorted out ,i am in n.ireland and our main hifi engineer is working on a sonus faber musica he may be able to help .
we are having trouble getting a schematic as surface mount resistors are damaged and absolute sounds the distributor wont help if you could help maybe we can help you in return
  Reply With Quote
Old 4th July 2011, 11:14 PM   #3
diyAudio Member
 
Join Date: May 2011
hi could anyone advise how we could get a schematic as absolute sounds says return amp to them -maybe we could source a schematic from some other source -there are a few surface mount resistors damaged and we need a little help or maybe advice -i heard audio analogue may have had something to do with the production of the musica many thanks for now
  Reply With Quote
Old 4th July 2011, 11:54 PM   #4
diyAudio Member
 
Join Date: Apr 2007
Quote:
Originally Posted by ronenash View Post
Hi all,

I need some help debugging a Sonus Faber Musica amplifier. I have the service manual (attached). I followed the instructions for setting DC offset and all worked fine. When I tried to set the quiescent voltage per the instruction on page 4, the left channel was not a problem and with the right channel no matter how much I turn the pot the voltage measired stays at 0mv.
The amplifier works and both channels play music although the right side of the heatsink where the output mosfets for the right channel are localted does not heat up as much under normal operation. I assume this is due to low bias current on that channel.

Can anyone assist in what could be the problem?

Service manual Musica (1).pdf - Windows Live

Thanks
ronenash.
Hello

Your service manual pdf file are not working, I've try to open it and there is an error message from my Adobe Reader.

Bye

Gaetan
  Reply With Quote
Old 17th July 2011, 07:57 PM   #5
diyAudio Member
 
Join Date: May 2011
i still have had no luck getting the service manual -the amplifier is mostly fixed just the surface mount resistors to replace
maybe in the meantime i can put a few pictures up of the amp and internals and the board that needs resistors replaced
many thanks for now
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sonus Faber Extrema bfard Multi-Way 119 15th August 2012 05:36 PM
Sonus Faber stradivari B4 Multi-Way 6 2nd August 2008 02:31 PM
Sonus faber cremona jouch Multi-Way 10 22nd September 2006 06:57 AM
Sonus Faber 2 way - Lute... mot on/off Multi-Way 0 11th April 2006 05:37 AM


New To Site? Need Help?

All times are GMT. The time now is 05:18 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2