Rega ELEX runs hot - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th January 2011, 11:59 PM   #1
diyAudio Member
 
mashley_nad's Avatar
 
Join Date: Apr 2009
Question Rega ELEX runs hot

I have just bought a Rega Elex, which works well - although the speaker relay needs a clean/replace as the RH channel only comes on if the volume is pushed a bit, but once on stays on.

It does run quite hot though - feels very warm to the touch.

A thermometer placed on the case reads 38 degrees C.

Is this normal for this amp???

Thanks

Last edited by mashley_nad; 11th January 2011 at 12:14 AM. Reason: added temperature
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does anyone have some idea about Rega Elex amplifer? wbhifi Solid State 62 29th September 2011 09:21 PM
Rega Elex service manual needed harhaug Solid State 7 12th February 2011 01:50 AM
Need Rega Elex Schematics Lewis Moon Solid State 6 6th September 2010 07:41 AM
OPA4228 runs hot iron25 Solid State 2 1st July 2007 05:42 PM
BOSOZ's PSU runs very very hot ruangrit Pass Labs 18 5th February 2003 11:45 PM


New To Site? Need Help?

All times are GMT. The time now is 11:36 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2