Crown MT1200 turn on click on channel 2? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th December 2010, 12:57 AM   #1
diyAudio Member
 
Join Date: Dec 2010
Default Crown MT1200 turn on click on channel 2?

I'm trying to diagnose a turn on click that seems to only occur on Channel 2 on a Crown Microtech 1200. Happens about 1-1.5 seconds after turn on - and before any audio output occurs.

Channel 1 never seems to do it.

I diagnosed why channel 1 wasn't working (ODEP off and 84v to speakers) - and it was multiple shorted outputs.. Other than replacing the shorted outputs, any other "preventative maintenance" or other overhaul I should consider?

Just wasn't sure where to even begin looking. I don't know what might contribute to the noise. Boards all look fine, caps look healthy.

Thanks in advance!
  Reply With Quote
Old 10th December 2010, 09:41 AM   #2
diyAudio Member
 
Join Date: Dec 2005
Location: silang, cavite
Send a message via Yahoo to audiomachines
disassemble, clean, re-lubricate bush bearing of the transmotorfan
  Reply With Quote
Old 10th December 2010, 02:43 PM   #3
diyAudio Member
 
Join Date: Dec 2010
Thanks. Appreciate it.

I realized that I hear a click on both channels... Just seemed louder in channel 2.

Will definitely look at the fan. I think one that I have has a slow fan..
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crown D-60 Dual-channel Power Amplifier User Manual For Sale mv331 Swap Meet 0 21st May 2009 05:37 AM
hifonics turn off thump/click marko Car Audio 0 2nd March 2009 04:08 PM
Crown CP660 (6 channel pro amp) Rybaudio Swap Meet 2 6th June 2008 03:30 AM
NAD 3130 left channel dropping in and out as I turn the volume control was8v Solid State 2 1st July 2007 06:16 PM


New To Site? Need Help?

All times are GMT. The time now is 08:26 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2