diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Solid State (http://www.diyaudio.com/forums/solid-state/)
-   -   Pioneer SX-1280 (http://www.diyaudio.com/forums/solid-state/177666-pioneer-sx-1280-a.html)

Pure_Brew 21st November 2010 09:33 PM

Pioneer SX-1280
 
Hi,
I got this receiver like 14 years ago and I've kept it in nice shape. It's been having some issues though. The right channel doesn't seem to want to come on until it's warmed up for awhile. I'm 99% sure it's preamp issue, since I can run a separate preamp into it without this problem.

Also, The left side will also want to cut out when I use the push button associated inputs. Wiggling them will bring it back. Avoiding them by using the associated tape toggle switched input avoids this issue. The tuner is on a push button input, so that can cut out too until I give it a wiggle-jiggle.

I brought the rcvr to a local family run repair shop that's been around for many years. I told them my issues, they took it and said they cleaned it but nothing really ever changed. Very disappointed needless to say.

I'm not sure where to begin, I don't think I should just spray cleaner into the switches themselves because i don't want to make a mess. Should I try to remove the front panel?

If you have worked on these before or have any insight (or schematic!?), let me know. Any help would be greatly appreciated.

Thank You.

johnmik 21st November 2010 10:21 PM

1 Attachment(s)
My experience with these old receivers is that the switches may need to be cleaned several times, the unit has to be opened up to get at some of the switches properly. this can be done by yourself if you are adventurous. (and have a service manual) Deoxit has to be sprayed into the switches to cleane the contacts, and the buttons have to be pushed many times with deoxit in there. If you read thru some of the similar posts an AK this subject comes up all the time.
Hope this helps.

John Mik

Here's an opened up 1280 from the bottom...

Pure_Brew 21st November 2010 11:34 PM

Thanks for the reply. That pic is enough to scare away a novice DIY'er...

I bet that shop that "serviced" my receiver didn't do that, hence the same issue continues.

johnmik 22nd November 2010 12:15 AM

Good luck whatever you do. Thats a fine receiver when it's brought up to snuff..
Happy Holidays

John Mik http://uspug.com/E/band.gif

jackinnj 22nd November 2010 01:49 AM

I'm surprised that you don't have issues with the volume control -- these are really fine receivers but the pots can be problematic.

I have one SX-838 with a new power supply and output stage -- another is an SX-1250 which has a great output and a truly inferior pre section.

Pure_Brew 22nd November 2010 11:56 AM

Thanks johnmik & right back at ya!
At least for now it works and sounds very nice (warmed up).

Jackinnj - As far as the volume goes, I've never noticed an issue. I don't know about the other ones you mentioned, but this one is a stepped attenuation. Also, I use the -20db muting often, since the first step is often too loud for late-night listening. I agree the preamp on these is an overall weak spot though.

east electronics 22nd November 2010 07:42 PM

well ... a fine machine but way too complicated unless your are an expert on vintage amps ...

here is a few things to look at

---isolate the problem ( well done so far )
---take samples of a few caps small electrolytics if one is leacky all of them need to be replaced
--- yeap !!! thats a pain in the @ss job to do
--- and yeap all means all ( average electrolytic has about 2.000 h of life and that apply only if not exposed to heat )
--- create a signal tracer..... that will be the cr@@piest computer speakers ( with the small amplifier included) you have ,install a small elctrolytic of 1 mfd/63 volt in the input to isolate dc if you connect there accidently and trace the signal from input to output to see where it gets lost ...

this is the simplest way to do it but still will require to know your way arround it ...

would you like a schematic ??? i will check if i have it .... hold on please ... ok ...i have it ...

e mail me if you want it ....bit small 60MB

kind regards sakis

Pure_Brew 22nd November 2010 09:19 PM

Thanks for the reply. Yeah this is pretty over the top. I've recapped an old piece of tube gear which had a ton of space = easy to work with. It was also a worthless hunk of electronics, so if I destroyed it - no loss.

I'll take you upon your schematic offer though, I really appreciate it Thanks!

Pure_Brew 22nd November 2010 10:21 PM

wow the FM tuner just quit working... awesome.


All times are GMT. The time now is 12:40 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2