Krell amp with channel imbalance - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 31st October 2010, 05:49 PM   #1
Johpat is offline Johpat  Sweden
Account disabled at member's request
 
Join Date: Apr 2006
Location: Sweden
Default Krell amp with channel imbalance

Hi!

I recently buyed a second hand Krell KAV-300iL amp and have now discovered that the left channel has 2-3db lower volume than the right channel. Would be nice to learn what is causing this and if it would be expensive to repair.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
krell ksa 300s right channel dead maybe transistor problem?? yipyip55 Solid State 25 19th July 2012 07:21 PM
channel imbalance!!!! need help tubo Tubes / Valves 5 10th December 2009 06:30 PM
Yaqin MC-100b channel imbalance al3700 Tubes / Valves 1 22nd October 2009 06:35 PM
Low volume imbalance lazyfly Solid State 6 26th June 2004 06:33 PM
Noise in one channel of krell KSA-80 Deoreo Solid State 2 30th March 2004 06:22 PM


New To Site? Need Help?

All times are GMT. The time now is 09:42 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2