How to set idle current with old STK modules - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th October 2010, 01:12 PM   #1
Orit is offline Orit  Italy
diyAudio Member
 
Join Date: Feb 2007
Location: Milano
Default How to set idle current with old STK modules

Hello,
after replacing the output modules on the amplifier as attachment, I noticed that idle current is too low. Am I right saying that idle current depends on voltage difference between pins 0 and 1 of the output modules, hence on VAS collector current ?
Thanks in advance, have a good day

Orit
Attached Files
File Type: zip Technics SU-7100_au.zip (256.6 KB, 37 views)
  Reply With Quote
Old 25th October 2010, 05:08 PM   #2
sregor is offline sregor  United States
diyAudio Member
 
Join Date: Jan 2006
Location: massachusetts
Yes - but the bias circuit is internal to the module and inaccessible. I suppose increasing the VAS current would increase the idle current, but would affect other things too. There is no simple fix to adjust the current. Are you measuring the current by the voltages on the output resistors? Is it different from the other channel? Have you checked the value of the .22 resistors? Parts change in the thirty years since this amp was originally range. Good luck with it.
__________________
Steve
  Reply With Quote
Old 26th October 2010, 08:34 AM   #3
Orit is offline Orit  Italy
diyAudio Member
 
Join Date: Feb 2007
Location: Milano
Steve,
thank you for your reply. Yes, there should be 20 mV on each output resistor, but I measure only 6 mV, and the resistor values are Ok.
Orit
  Reply With Quote
Old 26th October 2010, 05:11 PM   #4
diyAudio Member
 
EchoWars's Avatar
 
Join Date: Dec 2002
Location: Left of the Dial
There's a lot of bogus STK modules out there (probably from China) that have virtually no bias circuitry (or at least circuitry that isn't doing what it's supposed to).
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
STK series amp modules- any good? flyingtele Chip Amps 37 24th January 2014 02:47 PM
help setting up idle current lensmanMk2 Solid State 31 10th March 2010 11:48 PM
STK Modules FS 4bassman4 Chip Amps 0 20th October 2009 06:27 PM
Comparison between STK modules Tekko Chip Amps 2 13th July 2005 01:13 PM
SMPS Idle Current cm961 Parts 2 20th February 2004 05:56 AM


New To Site? Need Help?

All times are GMT. The time now is 06:28 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2