Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th October 2010, 08:48 PM   #1
diyAudio Member
 
Join Date: Jan 2009
Default Failed channel on Cyrus prex vs pre amp

I am a novice with a problem. I am vertically Bi-amping using the Cyrus pre and 2 integrated T amps but One channel of the Cyrus is dead.
What to do?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
6 channel pre amp? lbstyling Analog Line Level 13 21st July 2010 12:58 AM
6 Channel Pre-Amp suds Solid State 1 16th September 2008 07:41 PM
Pre amp 2.1 Channel senee Chip Amps 1 25th December 2007 01:54 PM
ARGH! One channel failed ... where to start? paulspencer Chip Amps 1 23rd July 2007 12:44 PM
Linn LK-2(60) One Channel has Failed. Anyone familiar with this circuit design? dtm1962 Solid State 0 11th April 2004 12:41 AM


New To Site? Need Help?

All times are GMT. The time now is 06:43 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2