How to troubleshoot Citation 22 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th October 2010, 05:28 AM   #1
ezjam is offline ezjam  United States
diyAudio Member
 
Join Date: Oct 2010
Default How to troubleshoot Citation 22

Hi,

I have a Citation 22 that has permanently gone into the Protect mode. I have the Service Manual thanx to a guy from AudioKarma. However, I do not know how to proceed.

I have a Fluke meter and access to other lab equipment. However, I would appreciate some pointers as to where to start.

Thanx in advance.

ezjam
  Reply With Quote
Old 13th October 2010, 09:31 AM   #2
Banned
 
Join Date: Jan 2005
ohm the output transistors and see which are shorted.

Also disconnect everything but the power cable and see if its a dc on the input/short on the speaker outputs issue before proceeding to troubleshoot the insides.
  Reply With Quote
Old 19th October 2010, 08:26 PM   #3
ezjam is offline ezjam  United States
diyAudio Member
 
Join Date: Oct 2010
Hi,

I measured all output resistor as suggested and none are shorted. However, while measuring the speaker outputs resistance, the Protect LED went off and the power came LED came on. Now every time I turn it on, the Protect LED is on for about 5 seconds and then shuts off and amplifier works as expected (I think.) I have not been able to do a through sound test as my citation 22 that I purchased with it is not working. I have tested it with a plain MP3 player, however, the sound coming out is not very pleasant.

I guess I have to get my hands on a pre-amp now.

Thanx for your help.

ezjam
  Reply With Quote
Old 19th October 2010, 09:51 PM   #4
ezjam is offline ezjam  United States
diyAudio Member
 
Join Date: Oct 2010
I measured all output transistors..

Quote:
Originally Posted by ezjam View Post
Hi,

I measured all output transistors suggested and none are shorted. However, while measuring the speaker outputs resistance, the Protect LED went off and the power came LED came on. Now every time I turn it on, the Protect LED is on for about 5 seconds and then shuts off and amplifier works as expected (I think.) I have not been able to do a through sound test as my citation 22 that I purchased with it is not working. I have tested it with a plain MP3 player, however, the sound coming out is not very pleasant.

I guess I have to get my hands on a pre-amp now.

Thanx for your help.

ezjam
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need to resurrect my HK Citation 22... Jim K Solid State 25 19th December 2013 07:09 PM
22+22 transformer thetube0a3 Chip Amps 173 13th March 2010 09:35 AM
Schematic for HK Citation 22 fabiodord Solid State 2 21st August 2007 12:14 AM
Help me troubleshoot this design, please teemuk Solid State 19 7th August 2006 11:07 PM
Help - Troubleshoot arkay Tubes / Valves 16 5th January 2002 06:53 AM


New To Site? Need Help?

All times are GMT. The time now is 03:18 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2