Technics SA-1000, I need help. - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th September 2010, 01:48 PM   #1
roban is offline roban  Sweden
diyAudio Member
 
Join Date: Sep 2010
Default Technics SA-1000, I need help.

Hi
I need help with parts for receiver Technics SA-1000. I bought it damaged. No pair of end-transistors 2SB600A and 2SD555A, I find this:
2SD555 and 2SB600 NEC Amplifier Transistors NOS 2 PCS. - eBay (item 300464586107 end time Oct-06-10 06:16:51 PDT)
It is ok?
Right channel have bruned drivers transistors:
2SA964A
2SC2224A
2SA1006B
2SC2336B
Perhaps there is more bad transistors, I do not know yet. Maybe anyone can help me to find this transistors or replacements.
Thank you and sorry for my english.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Counterpoint SA-1000 Cobra2 Tubes / Valves 3 16th March 2008 04:24 PM
Technics SA-G9057 vcard717 Solid State 0 7th January 2008 02:27 AM
Fisher SA 1000 caiman Tubes / Valves 0 21st November 2007 01:18 AM
Technics SA-600 ZigDaPig Solid State 0 16th August 2005 01:33 PM
Technics SA-X900L audioPT Solid State 2 6th May 2004 01:07 PM


New To Site? Need Help?

All times are GMT. The time now is 02:45 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2