crossfire cfa-602, car audio amp problem - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th September 2010, 12:56 PM   #1
tuneman is offline tuneman  Australia
diyAudio Member
 
Join Date: Feb 2004
Location: pitts of hell!!
Default crossfire cfa-602, car audio amp problem

hi

i dont post much but i thought you guys might be able to help me

i have a crossfire cfa602 amp that is making a weird high piched noise about 10 sec after its turned off!
thats with the rca's dissconected, mostly in the right channel and a little in the left.

i know this amp is getting on a bit(10-12years old!) but its 1 of 6 i am using at the moment, this one powers a set of usd HLCD's
if i recall correctly the amp at one stage of its life accidently had its 2 channels wired together, it shorted and blew the 30a fuse in one channel.

was that the likely cause?

anyone with any idears on what it is, i dont have a huge knowege of how they work but i can usually fix most things.

thanks
  Reply With Quote
Old 11th September 2010, 01:51 PM   #2
diyAudio Member
 
blakktalon's Avatar
 
Join Date: Jul 2010
Location: Federal, Seattle
You should post this in the car audio forum. Put up a picture of the inside of the amp, and best of luck to ya.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
First Post - Stumped on a Car Audio Problem KThug Car Audio 14 20th March 2010 01:23 PM
EXECUTIVE AUDIO XS 402 and XS 602 POWER AMP SCHEMATICS alexclaire Solid State 1 24th March 2009 07:41 AM
car audio problem mike49504 Car Audio 12 12th April 2007 10:59 PM
Problem w/Clipping new 2 car audio need help bmxkris Car Audio 2 4th April 2005 05:27 PM
Mirand A1 CFA-Amp (Pictures) welcome comments ! pixworld Solid State 23 11th January 2005 11:22 AM


New To Site? Need Help?

All times are GMT. The time now is 12:56 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2