diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Solid State (http://www.diyaudio.com/forums/solid-state/)
-   -   Arcam Alpha 5 Problem (http://www.diyaudio.com/forums/solid-state/172285-arcam-alpha-5-problem.html)

Grizzard 21st August 2010 07:52 PM

Arcam Alpha 5 Problem
 
I have an alpha 5 amp which was working fine until I packed it up to move house. However, upon setting up my system again, the amp, although powered-up, is not putting a signal out to the speakers. Does anyone have any ideas please?

jaycee 22nd August 2010 03:50 AM

do you hear a click after a few seconds? Does the power light turn green?

Grizzard 22nd August 2010 07:18 AM

Thanks for the reply, jaycee. The green light comes on, but there is no click and there is no sound whatever from the speakers. The amp was carefully transported and was switched off when I was removing and installing the cables.

Grizzard 23rd August 2010 06:08 PM

I've still made no breakthough on this problem. Does anyone know if it could be a relay or a fuse?

Charles Darwin 23rd August 2010 06:44 PM

I can't help much but I used to have an Alpha 8 (I think, it's been a long time!) which I bought new.
In the first 6 months it went back to the dealer 4x because something burned out in the psu (I was too annoyed to ask exactly what), leading to very similar symptoms.
Basically it was shoddy design work and eventually led to a quiet recall. If your dealer didn't have a technician (mine did) you could send it in.
Could be something similar as I don't know if it affected only the model I had or the whole range.

Grizzard 23rd August 2010 07:10 PM

Thanks, Charles. The amp is making a humming sound, if that is any more help.

Grizzard 24th August 2010 06:46 AM

Some success! I had a look inside and found a blown fuse on the output, which I replaced with the spare supplied. I now have sound on one channel, so I'm assuming the other fuse has blown too.


All times are GMT. The time now is 11:34 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2