What's wrong with my Onkyo amp? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th June 2010, 06:04 PM   #1
diyAudio Member
 
Join Date: Oct 2005
Default What's wrong with my Onkyo amp?

Hello all,

I woke up this morning and found that my old Onkyo A-10 no longer works. Initially, I thought it was completely dead. However, when I turn the volume up really high, I can hear sound but it sounds like just high frequencies. It sounds sort of "tinny". This amp is over 20 years old, but it worked fine as of about 1:00AM when I went to bed. Any ideas what could cause it to crap out all of the sudden? I haven't opened it up yet as I thought I would ask for some suggestions first. Thanks!
  Reply With Quote
Old 13th June 2010, 06:19 PM   #2
diyAudio Member
 
Join Date: Mar 2010
Check the Tape Monitor switch.
  Reply With Quote
Old 13th June 2010, 07:17 PM   #3
diyAudio Member
 
Join Date: Oct 2005
Boy, do I feel dumb! You are correct. The tape monitor switch wasn't set to source. I don't know how it got switched, but I switched it back and all seems well now. Thanks a lot!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cyrus 2 dead c32 & 31 wrong way help paul_peraic Solid State 0 29th May 2008 03:26 PM
Wrong Voltage / current on BoZ... or Wrong Measuring ? gionag Pass Labs 8 14th May 2008 11:24 AM
Onkyo A-SV620 something is wrong with left channel Jimmy154 Swap Meet 2 21st March 2007 10:20 PM
Onkyo A-SV620 something is wrong with left channel Chessmaster9000 Solid State 0 24th August 2006 01:15 PM
Onkyo A-SV620 something is wrong with left channel Chessmaster9000 Swap Meet 0 21st August 2006 07:28 AM


New To Site? Need Help?

All times are GMT. The time now is 08:10 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2