Rebuilding Soundcraftsman amp. Need advice, ID burnt resistor??? Pix attached... - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd June 2010, 05:42 PM   #1
diyAudio Member
 
Join Date: May 2010
Location: Minneapolis, MN
Default Rebuilding Soundcraftsman amp. Need advice, ID burnt resistor??? Pix attached...

I just got a Soundcraftsman MA 5002 Amp.

I am told it doesn't work. First I disconnected the bridge rectif, and checked for DC voltage. The transformer and rectifiers seem okay with +- 63vdc and +-40vdc.

Next I did a visual inspection, there is a board near the transformer that is fed from the main fuse on the back and feeds the main transformer. There is a red resistor sized device that looks like it is burnt, the board is stained all around it front and back. Any help on IDing this board would be great and what to replace? see pix (burnt device middle right).

What should I check next, before hooking the power back up to the mosfet boards?

Also any good ideas on the best way to clean the dust and crud off of all of the remaining circuit boards?

Thanks!

John
Attached Images
File Type: jpg IMG_0036.JPG (188.8 KB, 30 views)
File Type: jpg IMG_0013.JPG (155.3 KB, 29 views)
File Type: jpg IMG_0014.JPG (179.5 KB, 29 views)
  Reply With Quote
Old 2nd June 2010, 05:59 PM   #2
diyAudio Member
 
Join Date: May 2010
Location: Minneapolis, MN
Default Another Burnt component...

I noticed that there is a fried resistor right near the "red" device that is also burnt.

I'm still not sure what the red device is? I can probably figure out the value of the resistor and replace the cap...
Attached Images
File Type: jpg IMG_0011-2.JPG (186.3 KB, 26 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Burnt Tantalum Resistor Question milezone Solid State 2 30th September 2009 10:27 PM
Need some advice rebuilding/upgrading 2 power amps. SuperKris Solid State 31 26th May 2009 04:24 AM
Burnt & Destryed my virtual resistor! lineup Solid State 1 20th January 2009 03:42 AM
Advice needed about Lexsen power - photo attached Brit01 Solid State 2 28th July 2008 09:05 AM
Question on ID resistor Thomas001 Parts 1 1st May 2004 12:32 AM


New To Site? Need Help?

All times are GMT. The time now is 09:27 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2